07 WRX, Alarm-no Beep?
+ Reply to Thread
Results 1 to 12 of 12

This is a discussion on 07 WRX, Alarm-no Beep? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Ok searched a little under "alarm" and found an alarm chirp problem thread for an 05sti and another for an ...

  1. #1
    Registered User paolino's Avatar
    Join Date
    May 2007
    Location
    RAF Molesworth, UK
    Posts
    37

    07 WRX, Alarm-no Beep?

    Ok searched a little under "alarm" and found an alarm chirp problem thread for an 05sti and another for an 04..

    I called 5 Suby Dealerships around here and the service guys do not know enough about it (or are being lazy). They want me to bring it in, but I know that it will be fixed in 2 minutes and I do not wnat to lose that 1-2 hours of my life driving through traffic. SO...

    I walked outside the other day and pressed my unlock on the remote and the lights flashed, the car unlocked, but no beep came out. In the 07 at least (I guess 06 too) you hear a short electronic 2 beeps to unlock and one to lock. Well the security light blinks in the dash console as well, but I do not know how to bring it back. I flipped through the manual and read a little bit about arming and disarming, and valet mode but I do not think it is disarmed and it is not in valet mode, I believe.

    I called one dealership and a SALES guy that sold me the car asked me to try holding the lock button down for 5 seconds...the alarm went off. No go.

    Anyway its not a huge thing but I want to turn the beep back on, or at least know what I did to disable it.


    Anyone run into this?
    Like I said I did search but only one criteria. I figure easier to get it out and if someone does know, this can be a thread to add to the search for someone else in the future.

    Thanks in advance,
    Keith

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User paolino's Avatar
    Join Date
    May 2007
    Location
    RAF Molesworth, UK
    Posts
    37
    Anyone? Beuller?

  4. #3
    Registered User bikefreax's Avatar
    Join Date
    Jan 2006
    Location
    Columbia
    Posts
    403
    The back of my key fob says;

    1 press unlock once
    2 press lock and unlock together for 2 sec

    This either turns it off or on depending on where it is now. Mine is an 05 so not sure if its the same for yours. Its also in the manual someplace.
    '05 WRX Wagon San Remo Red, Stage ?????????????

  5. #4
    Registered User
    Join Date
    Apr 2007
    Posts
    24
    I also have an 07 with the same problem. Theres a menthod in the instructions on how to turn the audio on and off, but that didnt work for me, i also tried the holding lock and unlock, and that didnt work either

  6. #5
    Registered User paolino's Avatar
    Join Date
    May 2007
    Location
    RAF Molesworth, UK
    Posts
    37
    Thanks guys. I will try the press unlock and hold lock option.

    I am taking it to the dealership this evening, so we'll see what it was I did wrong...

  7. #6
    Registered User
    Join Date
    Apr 2007
    Location
    Modesto, CA
    Posts
    16

    Same Problem

    well mine is in the shop for the same exact ****.....ill find out monday if it was the wirng....the chirp speaker itself or something else......but whatever i find out what it might be or what it is ill let you know asap

  8. #7
    Registered User
    Join Date
    Apr 2007
    Posts
    24
    Went to the dealship yesterday for service and told them about my alarm problem. The guy at the desk said he got them to get the horn to beep when you lock or unlock the door.....but when i got home i realized that didnt happen, and i still dont have my chrip sound back.....and for whatever its worth mine didnt just stop one day outta the blue....it sounded like it was dying for a few days before

  9. #8
    Registered User gfred024's Avatar
    Join Date
    May 2006
    Location
    ga
    Posts
    295
    my 06 has the same problem. It still locks and unlocks fine but it only beeps when it wants to

  10. #9
    Registered User UnTuCHaBLeZ_WRX's Avatar
    Join Date
    Jul 2007
    Location
    CA
    Posts
    60
    Must be a common problem! But it is covered under warrenty

  11. #10
    Registered User Lithoss's Avatar
    Join Date
    Nov 2006
    Location
    Wichita, KS
    Posts
    167
    Sometimes mine doesnt chirp when i lock it as well. I keep pressing it expecting it to and eventually it honks at me .... i have no clue why

  12. #11
    Registered User fenderwrx's Avatar
    Join Date
    Apr 2007
    Location
    Southwestern MA
    Posts
    1,313
    look in your manual, but if you search nasioc, youll see a dead chirp is a very common problem. its not even worth it. i tried to have a dealer fix it. they said they did, but didnt. lame.
    Fender + WRX > Fender + VW...

  13. #12
    Registered User
    Join Date
    Apr 2007
    Location
    Modesto, CA
    Posts
    16
    well the dealer actully found the problem they says its the immobilizer ecu for the security system ordered the part and will be put in wednesday when the part gets there and they are reprogramming everything including new sets of keys all free of charge of course """warranty"""

    so if anyone has this problem that might be why your chirp doesnt work and by the way i have an 07 im not sure if thats for every wrx or not but yeah that was the problem for mine

    David
    (JULY 19th) Received my car...........if anyone has this problem it is most likely what i said above....
    Last edited by BluEwRx07; 07-19-2007 at 09:05 PM.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •