help with stock changer/radio please? (not turning off)
Results 1 to 9 of 9

This is a discussion on help with stock changer/radio please? (not turning off) within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Today i was changing some cd's and the radio locked up on me. I can't turn it off or on. ...

  1. #1
    Registered User Jared703's Avatar
    Join Date
    Apr 2002
    Location
    Fairfax, Va.
    Posts
    253

    help with stock changer/radio please? (not turning off)

    Today i was changing some cd's and the radio locked up on me. I can't turn it off or on. Its still on the same station (pop, it's killing me) and its at the same voulume. I pulled the radio fuse and that didn't do a thing. Any advice for me please? When i take the keys out its still on, the led is, but its not playing music. Only when its on the #2. acces. posistion on the ignition.

    thanks-
    Jared

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Jared703's Avatar
    Join Date
    Apr 2002
    Location
    Fairfax, Va.
    Posts
    253
    Anyone!? I don't want to have to try to reset the battery and loose what my ecu has learned about me in the last 3500k. Any other suggestions. Is there a reset button somewhere(on the radio)?

    Jared

  4. #3
    Registered User djrez4's Avatar
    Join Date
    Jul 2002
    Location
    Colorado
    Posts
    3,858
    No reset button. Take it in for warranty work. I'm getting my stereo replaced next week because it wouldn't play CDs.
    Deliberating enclaves of like-minded people are often a breeding ground for extreme movements - Cass Sunstein

  5. #4
    Registered User Jared703's Avatar
    Join Date
    Apr 2002
    Location
    Fairfax, Va.
    Posts
    253
    that is just ghetto though. I mean the car is like 2 1/2 months old! lol. What a pos radio. I guess when they do my oil change their going to have more to look at.

    Jared

  6. #5
    Registered User Vostok 7's Avatar
    Join Date
    Dec 2002
    Location
    Limehatless Avatar - I'm a trend scoffer.
    Posts
    1,141
    Just unplug the battery.

    I had the same problem with mine. Just unplug the battery and you'll be fine.

    I don't think the ECU will reset because I believe the ECU has a backup of some sort since it's a little more involved to reset the ECU than just unplugging the battery.

    The only thing you'll loose is the trip odometer's current reading.

    This is the third time I've heard of something like this happening in an '03... Interesting. And yours happened around the same mileage as mine as well!

    Mine happened the same exact way. I was just swapping CDs and then nothing. None of the buttons would work but the display still showed a radio station and the radio would play when I had the car running. Turning the car off would turn off the radio but the screen still displayed the station, etc. and the backlight was on.

    I'd unplug the battery and when you take it to the dealer ask them about it. Or don't mess with them and ask them about it (so you can prove it's a problem). I don't think it's serious but it is interesting that this has happened a few times and mostly to '03s.

    Vostok 7
    BUGEYE 4 LYFE! Or uh maybe not

    RIP Team Intrinsic Viva la Project 1! http://www.prjct1.com/

    2003 Subaru Impreza WRX Sedan 4EAT Aspen White "Akane"
    Mod List, Picts

    2004 Subaru Impreza WRX STi Sedan Aspen White "Akane II"

  7. #6
    Registered User Jared703's Avatar
    Join Date
    Apr 2002
    Location
    Fairfax, Va.
    Posts
    253
    I ended up just poping the main clock fuse, which also resets everything. Basically like taking the power off the batt. It works fine now, just needed to be reset. It was weird though. I'll mention it to the dealer tomorrow when i take it in for my oil change.

    Jared

  8. #7
    Registered User Vostok 7's Avatar
    Join Date
    Dec 2002
    Location
    Limehatless Avatar - I'm a trend scoffer.
    Posts
    1,141
    That's strange because I popped nearly every radio/clock fuse I could find and it did nothing for me.

    Hm.

    Vostok 7
    BUGEYE 4 LYFE! Or uh maybe not

    RIP Team Intrinsic Viva la Project 1! http://www.prjct1.com/

    2003 Subaru Impreza WRX Sedan 4EAT Aspen White "Akane"
    Mod List, Picts

    2004 Subaru Impreza WRX STi Sedan Aspen White "Akane II"

  9. #8
    Registered User Jared703's Avatar
    Join Date
    Apr 2002
    Location
    Fairfax, Va.
    Posts
    253
    the one in the main fuse, under clock (15a fuse) will do it. Its all the way to the right.

    Jared

  10. #9
    Moderator beastcivic's Avatar
    Join Date
    Mar 2002
    Location
    Charlotte, NC (USA)
    Posts
    1,832
    That happened to me, but I popped out the 'illumination' fuse (or something like that) in the engine bay because none of the interior ones seemed to work.
    -Jim

    '02 Platinum Silver WRX sedan w/roof rack...bone stock. Ok, now that's a lie.

    GO HOKIES!!!!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •