Sub install problem
Page 1 of 2 12 LastLast
Results 1 to 15 of 17

This is a discussion on Sub install problem within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I recently installed a sub and amp in my 2005 wrx and when I plug both RCA wires in to ...

  1. #1
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698

    Sub install problem

    I recently installed a sub and amp in my 2005 wrx and when I plug both RCA wires in to the amp it comes out muffled, but when I plug in either the left or right one it comes out, just for one side only. Any ideas what could be the problem? Any help would be appreciated, thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    bump

  4. #3
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    Its your settings on your deck. Did you also run your controll wire? What kind of deck do you have? Did you install the Deck yourself? Did you run your RCA's on the same side as your power?
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

  5. #4
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    I am using the factory head unit, I know I know; I bought a device from Car Toys that lets you hook into the speaker wires for the RCA, I did run a control wire as well. What do you mean "did you run your RCAs on the same side as your power"? Sorry my buddy helped me as I dont know too much about this stuff. Thanks for your help.

  6. #5
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    When installing the sub there needs to be three things plugged into the sub. Power, RCA's, Controll. Its very important that you run your power wire down the left side of your car and run the RCA's down the right side of your car, or visa versa. It is just not good to have your RCA's touching your power wire.
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

  7. #6
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    Ah gotcha. So you think that could be causing it? I will check and see which sides they were run down and switch them if necessary.

  8. #7
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    Quote Originally Posted by Houstonwrx View Post
    Ah gotcha. So you think that could be causing it? I will check and see which sides they were run down and switch them if necessary.
    That could be part of the problem. Just if they are running down the same side. Also I think part of the problem is your deck I hate to say. What kind of Sub and Amp is it? What kind of power is the Amp pushing? Where did you get your wiring kit? Do you know what gauge it is?
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

  9. #8
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    It is an off brand amp, got it for free, it says 1100 watts, the sub is Infinity 10". The gauge of wire is super thick, I do commercial real estate and one of our tenants, a stereo store, went out of business so I got the stuff for free, but I used the super thick monster cable on all the wires: power, RCA, and speaker. I mean it thumps hard for sure, harder than I desire. I got the RCA wire adaptor from Car Toys.

  10. #9
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    Any luck?
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

  11. #10
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    Nah man, not yet. I had my buddy do all the wiring and everything so I am waiting until the weekend. He is a mechanic for Land Rover/Jaguar so we can use his shop, because I live in an apt. with no place to work. I'll let you know how it goes......
    Thanks man.

  12. #11
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    meh I ran my RCA and power both down the left side. I assume by control wire you mean remote? I am using the stock HU as well. Sounds decent. I'm going to be getting a new HU in the near future. That should help out.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  13. #12
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    Yeah he means remote wire, that and control wire are the same thing. The speaker sounds great, it hits amazingly hard, too hard in fact. The biggest problem I have is that the WRX interior is so light and cheap the whole damn car rattles, its nuts.

    I have a low end Pioneer radio I could slap in there for free but I like stock as much as possible and I dont want to deal with another install, the sub and amp took I swear to god 6 hours to do, unbelievable.

    Does your car rattle big time, if not, what did you do to fix that, maybe some Dynomatt or something?

    Thanks.

  14. #13
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    A little bit of a trunk rattle and dashboard rattle. But it's not nearly as bad as I thought it would be. I'll probably dynomat later.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  15. #14
    Registered User Houstonwrx's Avatar
    Join Date
    Jul 2005
    Location
    Houston,TX
    Posts
    698
    My rattling all happens up front, I have my radar detector on top of my rearview mirror and the damn thing is about to vibrate off its position. Ill figure something out, I always do.
    Heck the door rattles from the crappy stock speakers it came with, so I planned on it rattling with a 10" inch sub in there.

  16. #15
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    Quote Originally Posted by Thug Nasty View Post
    meh I ran my RCA and power both down the left side. I assume by control wire you mean remote? I am using the stock HU as well. Sounds decent. I'm going to be getting a new HU in the near future. That should help out.
    Yah some do run them together but it does create a bit of static. For best quality it is best to run them of different sides.
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •