No Power in Amp
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on No Power in Amp within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I just bought a single channel amp and sub and I am gettting no power to the amp, the light ...

  1. #1
    Registered User BlueStallion's Avatar
    Join Date
    May 2006
    Location
    Rochester, MN
    Posts
    63

    No Power in Amp

    I just bought a single channel amp and sub and I am gettting no power to the amp, the light wont come on. I know everything is hooked up right because i have hooked them up before but i was wondering where you guys put your ground from the amp to the trunk. The first place I saw was on the trunk lid itself, on the arm of the trunk where there is already another ground that the car had so that is where i put mine but i was wondering if that is the reason i am not getting power and wanted to know where you guys put your ground?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Nov 2006
    Location
    South Jersey
    Posts
    245
    Quote Originally Posted by BlueStallion View Post
    I just bought a single channel amp and sub and I am gettting no power to the amp, the light wont come on. I know everything is hooked up right because i have hooked them up before but i was wondering where you guys put your ground from the amp to the trunk. The first place I saw was on the trunk lid itself, on the arm of the trunk where there is already another ground that the car had so that is where i put mine but i was wondering if that is the reason i am not getting power and wanted to know where you guys put your ground?
    I pulled out my back seats, and ran my ground lines to the lower seat belt bracket. They usually make good grounds because those bolts have to be attached to the frame. Just make sure u put it so that its UNDER all the seat belt equipment closest to the body, and scrape away any paint that is there so that u are sure to have a bare metal to metal connection. I have 2 amps, each is grounded this way to the seatbelt bolt on that respective sides, and they work great. I mounted my amps to the backs of my seat that way the ground is 3ft or less.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •