Clutch Pedal Squeak!?
Results 1 to 6 of 6

This is a discussion on Clutch Pedal Squeak!? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I have a 2004 WRX STI, and my clutch pedal squeaks slightly, and it drives me nuts. Is there anything ...

  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    14

    Clutch Pedal Squeak!?

    I have a 2004 WRX STI, and my clutch pedal squeaks slightly, and it drives me nuts. Is there anything I can do about it?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User DTR rex's Avatar
    Join Date
    Jun 2003
    Location
    Chi-town, IL
    Posts
    27,076
    Mine squeaks when cold as well. It is normal.
    Just call me Clark Kent
    ---------------------------------------
    Offical Body Guard for the Bugeye Mafia.

  4. #3
    Registered User kingkeegan's Avatar
    Join Date
    Nov 2005
    Location
    Boston
    Posts
    165
    My old 03' use to squeak soooo loud. I complained everytime I brought in for service. Everytime they said they would take care of it and they did, The fix usually lasted about a week. Grease does not work.
    NEW ENGLAND F4
    GO SOX!!

    Quote Originally Posted by gasstationboi
    I have no knowledge what so ever about subarus at all...:
    my head is screwy.

  5. #4
    Registered User
    Join Date
    Nov 2006
    Posts
    14
    It just started squeaking at like 9500 miles. :\

  6. #5
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    Quote Originally Posted by DTR rex View Post
    It is normal.
    +1

    i took my car back to the dealer because of this and they kept it overnight and the next day they told me it was normal
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  7. #6
    Registered User Lithoss's Avatar
    Join Date
    Nov 2006
    Location
    Wichita, KS
    Posts
    167
    I have an 06 with 7500 miles and on it and it squaks once in a while... pretty rare though, and i can't reproduce it...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •