05 STi cluster into any Pre-05 WRX
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on 05 STi cluster into any Pre-05 WRX within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; 02-03s (possibly 04s and 05s) suffer from a few problems when installing the 05+ STi Clusters: Loud buzzing blown fuses ...

  1. #1
    Registered User Chapel's Avatar
    Join Date
    Dec 2006
    Location
    Beverly MA
    Posts
    101

    05 STi cluster into any Pre-05 WRX

    02-03s (possibly 04s and 05s) suffer from a few problems when installing the 05+ STi Clusters:
    Loud buzzing
    blown fuses on the radio
    ABS Light
    Rear Diff light

    The fix is rather simple and doesn't require soldering anything or ripping out the buzzers or any of that.

    Tools required:
    Phillips head screwdriver (stubby and normal length)
    Wire cutters
    Wire strippers
    Crimp on insulated quick connects
    Wire crimper

    Step 1: remove the cluster
    Trunk Monkey has a good explanation of this.

    Step 2: Carefully file down the one little peg in the STi cluster that will keep the stock plug on the left from going in

    Step 3: locate the two wires
    on the MAIN plug, cut wire B28 (yellow/green)


    crimp on some quick connects should you ever have to plug it back in for the stock cluster.
    on the RIGHT side plug, cut wire A9 (orange/white)


    Again, crimp on some quick connects.

    Step 4 is optional and involves silencing the R.Diff Temp light. The EASIEST solution is to simply throw some electrical tape over it.
    The more ADVANCED way to do it is to Ground pin 4 but I was fine with just taping it.

    Step 5 is the ABS Light. At this point, no good solution has been found. I taped it and left a LITTLE of the bottom of the A showing so that if the ABS DOES fail, I'll see the little yellow light go off. The solution involves backwards wiring the ABS circuit on the board to be OFF all the time until failure.

    Step 6. Now, plug the plugs back in. The plugs are upside down on the STi, so just flip the cable ends over and plug them in.
    I suggest plugging the left one in first as that's the plug end with 16 pins instead of the 14 on the WRX Harness.

    Step 7. Shove everything back in, screw it all together and...






    Set your redline and enjoy.

    The redline buzzer will NOT work, just to let you know.
    All the gauges work, the 'lights on' light even turns on to let you know that your... lights... are on.

    So, there you have it... the FINAL SOLUTION to 05 STI clusters. Enjoy!
    Last edited by Chapel; 12-28-2006 at 05:40 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Chapel's Avatar
    Join Date
    Dec 2006
    Location
    Beverly MA
    Posts
    101
    tada

  4. #3
    Registered User
    Join Date
    Dec 2006
    Location
    CaLi
    Posts
    442
    nice

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •