Problem with ProSport Install
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Problem with ProSport Install within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I got Prosport electronic Boost and Oil Pressure gauges along with an autometer instrument panel bezel gauge pod. I got ...

  1. #1
    Registered User jaqattack02's Avatar
    Join Date
    Sep 2005
    Location
    Richmond, Va
    Posts
    1,339

    Problem with ProSport Install

    I got Prosport electronic Boost and Oil Pressure gauges along with an autometer instrument panel bezel gauge pod. I got the pod in, and the power wiring to the gauges all installed fine. They light up, and change from white to green just fine. The problem comes from actually having the readings on the gauges. The only one hooked up right now is the boost gauge, I'm waiting on the oil galley plug to come in so I can put in the oil pressure sender. I put in the T fitting, ran the line to the sender, ran the wires through to the cabin. I hooked the switched power up to the clock pod, just like the gauges, and hooked the correct wire to the gauge.

    Basically it seems like no signal is going to the gauge, as after it starts up it and goes through it's startup thing, it just points straight down. We checked everything we could think of and couldn't find anything wrong. Assuming I didn't even hook up the boost line, I should at least be getting a zero reading, but it just constantly points straight down, just like the oil pressure gauge, which isn't even hooked to a sender. We checked the power line with a multimeter and it was showing voltage, so the sender is getting power, but when we checked the signal line to the gauge it didn't pick up anything. What do you guys think, bad sender?
    Blobeye Syndicate #035
    Cobb Stage 2

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bikefreax's Avatar
    Join Date
    Jan 2006
    Location
    Columbia
    Posts
    403
    I have the same boost gauge and it points straight down also unles you are actually driving, then it starts moving up but remember it also measures the vacuum when you are not boosting. Hey I have a question, you say yours are wired for white in day and green at night? If you dont turn your lights off when you park and shut the car off does yours only stay white when you turn the car back on? I have a tendacy to leave the lights on since they shut off automatically but then it only lites up whit until you turn the lights off, and turn the car off. Kind of funny.
    '05 WRX Wagon San Remo Red, Stage ?????????????

  4. #3
    Registered User jaqattack02's Avatar
    Join Date
    Sep 2005
    Location
    Richmond, Va
    Posts
    1,339
    Quote Originally Posted by bikefreax View Post
    I have the same boost gauge and it points straight down also unles you are actually driving, then it starts moving up but remember it also measures the vacuum when you are not boosting. Hey I have a question, you say yours are wired for white in day and green at night? If you dont turn your lights off when you park and shut the car off does yours only stay white when you turn the car back on? I have a tendacy to leave the lights on since they shut off automatically but then it only lites up whit until you turn the lights off, and turn the car off. Kind of funny.
    Yes, I realize that it also measures vacuum, but when the car is idleing it should be sitting around 0, not pointing and -30, and even when driving the needle never moves.

    Yeah, mine shows white till you turn the lights on, then goes green, and if youu turn off the car with the lights on, and start it again, the gauge comes on white, and won't change to green unless you turn off the lights and the car.

    I got an email back from prosport yesterday and they said it sounds like a bad sender. They said they would replace it, I just have to send them the broken one.
    Blobeye Syndicate #035
    Cobb Stage 2

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •