Need input ASAP (Prosport)
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on Need input ASAP (Prosport) within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Hey all, I am in the process of installing my Prosport Mech Boost gauge as we speak. I have everything ...

  1. #1
    T8R
    T8R is offline
    Registered User T8R's Avatar
    Join Date
    Jul 2006
    Posts
    13

    Got the install done. Prosport Boost

    Hey all,

    I am in the process of installing my Prosport Mech Boost gauge as we speak. I have everything done, except the fact that i cannot get the damn boost gauge hose on the "Tee" I have tried liquid soap, i am gonna crack out the KY and see if that will do it. I am getting VERY frustrated. It almost seems as though the hose that came with the gauge has too small of an ID for the tee. OH ya also where should I cut the vac/bpv hose. I have an 06 and every how too says to cut it 80mm/ 1 in past the bend. From all the pics I have ever seen the bend is totally different from 02-03 to 06. Does anyone have an ideas for me ,,

    Thanx,

    Chris
    Last edited by T8R; 12-07-2006 at 08:03 PM. Reason: I do not need the help since the install is done

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    T8R
    T8R is offline
    Registered User T8R's Avatar
    Join Date
    Jul 2006
    Posts
    13
    Well I got it all buttoned up. I think it would have gone alot faster if I had an extra hand. I didn't have to break out the KY to get that damn hose on, just had to try my patience.
    Here are a couple pics of it in and on.,,






    Thanx to all that I asked for help with the install.
    Chris

  4. #3
    Registered User bikefreax's Avatar
    Join Date
    Jan 2006
    Location
    Columbia
    Posts
    403
    Looks good. I have the same set just not installed yet. I did not like the finish on the subie gal pod so I sanded it smooth and am painting it a flat black. Just not a fan of all the little bumps that were on it. Plus it had some spots where the bumps were gone and it looked funny.
    Any problems with the install I should be aware of?
    '05 WRX Wagon San Remo Red, Stage ?????????????

  5. #4
    T8R
    T8R is offline
    Registered User T8R's Avatar
    Join Date
    Jul 2006
    Posts
    13
    The one thing I had a bit of a time with was getting the boost hose onto the Tee.
    Other than that it would have gone alot quicker if I had someone helping me, to pull/watch wires and such.
    It's good to have some scrap lengths of wire to use to "fish" the boost hose through the firewall. Cause when I took the grommet out all there was was insulation, I fed the wire down to the hole that was probably supposed to be there till I could see it. Grabbed it in the cabin, I then taped the hose to it and pulled it through. I also used this method to get the hose up to where I wanted it by the A pillar. For wiring I just went to the fuse box, and used fuse tabs on the illum and the cig/mirr. Oh ya if your hose is still coiled up in the box,, take it out and straighten it. I should of done that the day I got it.

    TTYL,

    Chris

  6. #5
    Registered User bikefreax's Avatar
    Join Date
    Jan 2006
    Location
    Columbia
    Posts
    403
    I bought the new electrical boos gauge so my hose should not need to go through the firewall. I will probably mount the sensor in the engine compartment someplace. Should not be to hard. Do you like the gauge so far? And was your pod real speckeled with bumps to?
    '05 WRX Wagon San Remo Red, Stage ?????????????

  7. #6
    T8R
    T8R is offline
    Registered User T8R's Avatar
    Join Date
    Jul 2006
    Posts
    13
    Ya my pod had the texturing on it as well. I kinda liked it like that. I haven't really seen the gauge other than when I installed it and when I ran to Canadian Tire to grab zip ties. Plus we have a WHACK of snow so I'm just trying to steer clear of the roads right now. If I have to go out I'm using the 240 anyways.

    TTYL,

    Chris

  8. #7
    Registered User Lithoss's Avatar
    Join Date
    Nov 2006
    Location
    Wichita, KS
    Posts
    167
    That 240 is probably horrid in the snow? Whereas the WRX kicks ass in snow, but then again, you're probably more worried about the other idiots out there in their big SUV's and trucks that think just because its big its good in the snow.... Don't blame ya

    So what kind of boosts are you reading with your gauge? Are you still stock?

  9. #8
    T8R
    T8R is offline
    Registered User T8R's Avatar
    Join Date
    Jul 2006
    Posts
    13
    Quote Originally Posted by Lithoss View Post
    That 240 is probably horrid in the snow? Whereas the WRX kicks ass in snow, but then again, you're probably more worried about the other idiots out there in their big SUV's and trucks that think just because its big its good in the snow.... Don't blame ya

    So what kind of boosts are you reading with your gauge? Are you still stock?
    Ya the 240 kinda sucks but it's pretty damn fun at the same time. You're right about everyone else on the roads.
    I am basicalliy stock, and it seems as though In 1st, 2nd I am running around 7psi but If I tromp on it, it spikes a bit higher. 3rd around 10-11. 4th no idea really since the roads are not the greatest and I'm not on the highways at all.

    TTYL,
    Chris

  10. #9
    Registered User Lithoss's Avatar
    Join Date
    Nov 2006
    Location
    Wichita, KS
    Posts
    167
    Quote Originally Posted by T8R View Post
    Ya the 240 kinda sucks but it's pretty damn fun at the same time. You're right about everyone else on the roads.
    I am basicalliy stock, and it seems as though In 1st, 2nd I am running around 7psi but If I tromp on it, it spikes a bit higher. 3rd around 10-11. 4th no idea really since the roads are not the greatest and I'm not on the highways at all.

    TTYL,
    Chris
    K good, thats about what i get in 3rd.. i was worried i had a leak because many people (pre '06, which makes sense because of the smaller engine) claim around 14-15 psi stock

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •