Eclipse AVN5435 install
Results 1 to 2 of 2

This is a discussion on Eclipse AVN5435 install within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I just got this Nav unit and was wondering if I'm going to need any extra wires for the install ...

  1. #1
    Registered User
    Join Date
    Apr 2005
    Location
    FL
    Posts
    84

    Eclipse AVN5435 install

    I just got this Nav unit and was wondering if I'm going to need any extra wires for the install or does it just hook up to the factory harnesses. Also is it neccesary to run the reverse wire all the way from the front to the rear of the car? If there is another way to hook up reverse please let me know. Thanks for all the help.


    -WILL

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User flyingpertyhigh's Avatar
    Join Date
    Mar 2006
    Location
    Brookline MA
    Posts
    164
    Quote Originally Posted by Black_Rex
    I just got this Nav unit and was wondering if I'm going to need any extra wires for the install or does it just hook up to the factory harnesses. Also is it neccesary to run the reverse wire all the way from the front to the rear of the car? If there is another way to hook up reverse please let me know. Thanks for all the help.


    -WILL
    hi i just put one of these into my 03 rex. you need a wiring harness to hook up the wires to the subaru end. you can purchase one through crutchfield. with that, you have to run the wires and do a lot of crimping and soldering.

    it IS necessary to have the parking brake wire hooked up to something, whether you just ground it or actually hook it up tot he brake, otherwise you can't enter addresses. the reverse wire i just ran because I had to run the GPS antenna anyway to the trunk, so I just ran the reverse along with it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •