2004 wrx High beam indicator dash light not working
Results 1 to 4 of 4

This is a discussion on 2004 wrx High beam indicator dash light not working within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; yesterday i was replacing an Hid bulb in my 2004 wrx, and also doing the day running light delete, after ...

  1. #1
    Registered User
    Join Date
    Mar 2014
    Posts
    2

    Unhappy 2004 wrx High beam indicator dash light not working

    yesterday i was replacing an Hid bulb in my 2004 wrx, and also doing the day running light delete, after i was finished i noticed that the high beam indicator on the dash wasnt working so today i un-do the DRL delete and plugged everything back in. the high beam indicator on the dash is still not working tho ( the high beams work, also the low beams, turn signals, but not the little blue high beam indicator. i tried looking everywhere but no luck of this issue, on general chat someone said that it might be the dash light because its a very old car. please help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User LogiMech's Avatar
    Join Date
    Mar 2008
    Location
    the sticks, Colorado
    Posts
    47
    Looks like he helped you, replace the high-beam dash bulb.

  4. #3
    Registered User
    Join Date
    Mar 2014
    Posts
    2
    is it difficult to do it?

  5. #4
    Registered User LogiMech's Avatar
    Join Date
    Mar 2008
    Location
    the sticks, Colorado
    Posts
    47
    No, probably like 5 minutes. The "shroud" around the cluster has 2 screws at the top. Then the actual cluster has 3 screws. Unplug the cluster and look at the back. The circuit board is labeled, just look for high-beams or take an estimate of which bulb it is. Put it back together.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •