STi cluster swap issue NEED HELP!!!
+ Reply to Thread
Results 1 to 11 of 11

This is a discussion on STi cluster swap issue NEED HELP!!! within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; So I have a 06 WRX that I did a 6speed swap on. I also got a sti cluster and ...

  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    15

    STi cluster swap issue NEED HELP!!!

    So I have a 06 WRX that I did a 6speed swap on. I also got a sti cluster and installed it (I installed it according to one of the forums on here, and my buddy did the same with his 02 and it works fine) ok so here's my problem. I started the car and my speedo goes up to 60 mph (it does change a little depending on how much it rev's) and the odometer starts counting miles. Before i did the cluster swap i drove it to test the 6speed. On the original cluster the speedo didnt work (only after i did the 6speed swap) and i had a code pop up for speed sensor A low volts. Not sure what's wrong, I was hoping someone on here could help me. Thanks in advance!
    Last edited by DUST 3000; 04-02-2013 at 06:45 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,197
    So...in all that you explained up there...what's the problem? The cluster or the code for Speed Sensor low volts?
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    ProcessWest TMIC Cobb SF Intake w/airbox Invidia Catless Downpipe Invidia Q300 Catback Kartboy Short Shifter
    OpenSource tuned by: Matty @ WTF Tuning

  4. #3
    Registered User
    Join Date
    Jun 2011
    Posts
    15
    My problem is i'm at a dead stop with my car in neutral and my speedo is reading 60mph

  5. #4
    Registered User
    Join Date
    Jun 2011
    Posts
    15
    Just to be clear, it drives great. but the speedo is moving with the rpm's, the move i rev the higher the speedo goes.

  6. #5
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,197
    Ohhhhhhhhhhhhhhhhhhhhhhhhhhh. I gotcha now...so when you're going 60...it says you're going 120. Better slow down

    IIRC, there were some pins that might need to be moved. I'm not familiar with the thread you followed here, but I do know that there are some people here that have done it. PM username "Rambo" here.

    Also you might find some answers in this thread: STi cluster swap FAQ - can we get one started? - NASIOC
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    ProcessWest TMIC Cobb SF Intake w/airbox Invidia Catless Downpipe Invidia Q300 Catback Kartboy Short Shifter
    OpenSource tuned by: Matty @ WTF Tuning

  7. #6
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,713
    I Support ClubWRX I Support ClubWRX
    Sounds like you've got it hooked up wrong.

  8. #7
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Portland, OR
    Posts
    5,132
    I Support ClubWRX
    Quote Originally Posted by DUST 3000 View Post
    So I have a 06 WRX that I did a 6speed swap on. I also got a sti cluster and installed it (I installed it according to one of the forums on here, and my buddy did the same with his 02 and it works fine)
    So you have an 06 WRX, but what year STI did your cluster come out of? That's key.

    Yeah, refer to this thread like Mikie suggested. STi cluster swap FAQ - can we get one started? - NASIOC

    Swapping an '04 STI cluster into a 2003 is probably the easiest of all cluster swaps. It gets progressively more difficult in later years.
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    The pursuit of knowledge is hopeless and eternal... Hooray!!! - Professor Farnsworth

  9. #8
    Registered User
    Join Date
    Jun 2011
    Posts
    15
    Its a 2007 STi Cluster in a 2006 WRX. it could be that its wired wrong. My buddy did it from a 2004 STi to a 2002 WRX. Any help on how to wire up a 2007 to a 2006?

  10. #9
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Portland, OR
    Posts
    5,132
    I Support ClubWRX
    Quote Originally Posted by DUST 3000 View Post
    Any help on how to wire up a 2007 to a 2006?
    Did you read the link that was posted?
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    The pursuit of knowledge is hopeless and eternal... Hooray!!! - Professor Farnsworth

  11. #10
    Registered User
    Join Date
    Apr 2013
    Location
    Kinross, Scotland
    Posts
    18
    Am about to do this very same swap - I shall read the thread carefully!

  12. #11
    Registered User
    Join Date
    Apr 2013
    Location
    Kinross, Scotland
    Posts
    18
    How dd you get on by the way, is there anything I should look out for in your opinion?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •