Problems w/ streaming bluetooth audio, steering wheel controls and my Droid RAZR Maxx
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19

This is a discussion on Problems w/ streaming bluetooth audio, steering wheel controls and my Droid RAZR Maxx within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; As the title states I have a Droid RAZR Maxx and just got the Ice Cream Sandwich update. Everything is ...

  1. #1
    Registered User djclue8713's Avatar
    Join Date
    Aug 2010
    Location
    Springfield, MA
    Posts
    567

    Problems w/ streaming bluetooth audio, steering wheel controls and my Droid RAZR Maxx

    As the title states I have a Droid RAZR Maxx and just got the Ice Cream Sandwich update. Everything is great except for Bluetooth. I paired my WRX with the phone using the steering wheel controls (recommended after searching around online). I use Spotify to listen to music in the car (can't recommend this app enough. Well worth the $10/month), and previously I could skip/return to songs using the steering wheel controls or the knob on the radio.

    After this update, some weird stuff started happening. Now, I can only change songs using the steering wheel controls when 1) Spotify is the active app on the screen, and 2) The phone is not locked. So now when I want to skip around the music selection I have to wake up my phone and make sure the phone/text app isn't the active application. I might as well just use the lockscreen widget to change songs.

    This morning, the steering wheel controls didn't work at all. I didn't have time to mess with it so I just used the phone to change songs when I was waiting at a light. I did find this setting in the Settings > Security. I checked this "Allow Bluetooth Bypass" box and then rebooted my phone. Hopefully it works on the way home but I was wondering if anyone else had this particular issue with their Android handset?


  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User etnpnys's Avatar
    Join Date
    Dec 2011
    Location
    SoCal
    Posts
    756
    I have an old school EVO 4G with ICS. My '12 WRX steering wheel controls don't do anything with controlling music on my phone. Can't say I know how to fix your problem, but I'm interested and at least now I'm subscribed to this thread.
    "Ah, it is the fault of our science that it wants to explain all; and if it explain not, then it says there is nothing to explain."
    -Van Helsing, from Bram Stoker's ​Dracula

  4. #3
    Registered User
    Join Date
    Aug 2011
    Location
    Dobbs Ferry, NY
    Posts
    226
    I too had an old EVO but ran a non-sense ROM which was actually nice cause it showed the title and song name on the head unit and my steering wheel controls work perfectly... Now I'm on the new EVO (which comes with ICS) and I had issues with it in the beginning but someone told me to completely delete my previous phone via the controls on the steering wheel.

    So maybe try that? Completely delete the phone off the car and then pair it again.

  5. #4
    Registered User etnpnys's Avatar
    Join Date
    Dec 2011
    Location
    SoCal
    Posts
    756
    Quote Originally Posted by Alternet View Post
    I too had an old EVO but ran a non-sense ROM which was actually nice cause it showed the title and song name on the head unit and my steering wheel controls work perfectly... Now I'm on the new EVO (which comes with ICS) and I had issues with it in the beginning but someone told me to completely delete my previous phone via the controls on the steering wheel.

    So maybe try that? Completely delete the phone off the car and then pair it again.
    Which ROM were you running where you had control via the steering wheel?

    And +1 to deleting the "old" phone first and then trying again. Good call. I have to do this every time I flash a new ROM.
    "Ah, it is the fault of our science that it wants to explain all; and if it explain not, then it says there is nothing to explain."
    -Van Helsing, from Bram Stoker's ​Dracula

  6. #5
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,981
    Quote Originally Posted by etnpnys View Post
    Which ROM were you running where you had control via the steering wheel?
    +1 to that question, I still have an Evo 4g, and would love to have a better connection since I use my phone for music. Song name display would be nice!
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

  7. #6
    Registered User djclue8713's Avatar
    Join Date
    Aug 2010
    Location
    Springfield, MA
    Posts
    567
    UPDATE: When I drove home last night it worked flawlessly. I then even took it a step further and unchecked that "Bluetooth Bypass" setting and the steering wheel controls still worked with the phone locked. I was very happy!

    ..And then this morning the same thing happened. No steering wheel controls, but audio and phone calls were fine. I'm looking into the "Moto Smart Actions" to see if this has anything to do with it. I do have a "Car" profile which runs on a time schedule for my AM/PM commute. It starts Bluetooth and launches Spotify. The phone isn't having any trouble auto-connecting once the car is started, just these flaky steering wheel control issues!

    I also came from an Evo 4G. That thing worked like a champ! Whenever I flashed ROMs I made sure to delete the phone from the car and pair it again. Could never get the non-sense ROMs to work reliability though.

    I'll try to delete the phone from the stereo and try again. I did this when I upgraded from gingerbread to ICS but we'll see how it goes.

  8. #7
    Registered User etnpnys's Avatar
    Join Date
    Dec 2011
    Location
    SoCal
    Posts
    756
    Well, just to put it out there: I blame Android rather than the car... So I would focus most of the efforts on that front. Are you using Tasker for your profile thing? I have found apps like that tend to cause issues like this...
    "Ah, it is the fault of our science that it wants to explain all; and if it explain not, then it says there is nothing to explain."
    -Van Helsing, from Bram Stoker's ​Dracula

  9. #8
    Registered User hisdigness's Avatar
    Join Date
    May 2010
    Location
    So Cal (Torrance)
    Posts
    324
    Hey, just stumbled across this thread. I don't have a solution, but I did want to mention that many people have had issues with Bluetooth and WiFi after upgrading to ICS. You may want to google it to see if there is a fix. Or wait for an OTA update. Hope that helps some.

  10. #9
    Registered User
    Join Date
    Apr 2012
    Posts
    279
    The new ICS builds are still not right. (I flashed it onto my bionic) and the siriusxm app doesn't run as supposed to sometimes.

  11. #10
    Registered User
    Join Date
    Aug 2011
    Location
    Dobbs Ferry, NY
    Posts
    226
    For those who were asking about that ROM I used.

    Here's the link

    MikG ROM 3.0

    Very very stable ROM for the OG EVO and very smooth as well. I think it's 100x better than stock ROM.

    Good luck!

  12. #11
    Registered User etnpnys's Avatar
    Join Date
    Dec 2011
    Location
    SoCal
    Posts
    756
    Quote Originally Posted by Alternet View Post
    For those who were asking about that ROM I used.

    Here's the link

    MikG ROM 3.0

    Very very stable ROM for the OG EVO and very smooth as well. I think it's 100x better than stock ROM.

    Good luck!
    Ah! I was running MikG for a long time actually (before I got the car). But I thought his stuff was all Sense based?

    (Maybe we should stop hijacking the thread...)
    "Ah, it is the fault of our science that it wants to explain all; and if it explain not, then it says there is nothing to explain."
    -Van Helsing, from Bram Stoker's ​Dracula

  13. #12
    Registered User djclue8713's Avatar
    Join Date
    Aug 2010
    Location
    Springfield, MA
    Posts
    567
    My Razr is not rooted and I received the OTA update (I didn't have to wait that long, I just picked this phone up 3 weeks ago). I'm definitely pinning it on the phone and not the Rex. I don't have any 3rd party profile managers. Just the stock "Smart Actions" app from Motorola. But that shouldn't matter much either because all it does is enable BT for a set amount of time.

  14. #13
    Registered User
    Join Date
    Aug 2011
    Location
    Dobbs Ferry, NY
    Posts
    226
    Quote Originally Posted by etnpnys View Post
    Ah! I was running MikG for a long time actually (before I got the car). But I thought his stuff was all Sense based?

    (Maybe we should stop hijacking the thread...)
    Haha sorry one more time.

    Yes you are right it is Sense based.. I completely forgot the last ROM I ran on my phone due to trading it in, I cannot find out either. But I did run MikG for a while.. and it was very stable.. I am 90% sure that CM7 was able to work properly with steering wheel controls as well as show you the artist title and album on stock non-navi HU.

    Back to being on topic. I do agree it's the new OTA. Best bet is to really just sit down and mess around with it in your car

  15. #14
    Registered User djclue8713's Avatar
    Join Date
    Aug 2010
    Location
    Springfield, MA
    Posts
    567
    Yea that's what I plan on doing at this point. Now I'm really interested in displaying track/artist information on the headunit without flashing a custom ROM. I would love to have that feature.

    Sent from my DROID RAZR using Tapatalk 2

  16. #15
    Registered User
    Join Date
    Aug 2011
    Location
    Dobbs Ferry, NY
    Posts
    226
    I don't know about the Droids but I am fairly all the HTC phones won't work like that.. I really wish so too but there aren't any stable ROM's for the new EVO...

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •