Boost Gauge Question - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20

This is a discussion on Boost Gauge Question within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Originally Posted by Ingo Gotta chime in here: at ingition on with the engine not running the intake pressure HAS ...

  1. #16
    Registered User Major25's Avatar
    Join Date
    Apr 2012
    Location
    New Hampshire
    Posts
    29
    Quote Originally Posted by Ingo View Post
    Gotta chime in here: at ingition on with the engine not running the intake pressure HAS to be 0 (zero) !
    If it's not the gauge is just junk, or wired wrong,or off-calibration, or... take your pick....

    So, the picture in the original post is with the engine running in idle?

    No I'm sorry, the picture in the OP was one I found online to just show you what my gauge looks like. I can take a couple pictures of it tomorrow, but it does not sit at zero with the ignition on but the engine not running, if I understand what you mean I believe it's at -24 at that point. I'll post a couple pictures tomorrow, but as of right now I'm almost positive the gauge isn't functioning properly. Thanks again for all your input, I'm new to this stuff.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    24" mercury equals 11 psi. Add that to your reading (0-5psi) and you're getting the 14psi boost... So time to ask for your money back on the gauge... your car's fine....
    You can't have everything - where would you put it?

  4. #18
    Registered User Major25's Avatar
    Join Date
    Apr 2012
    Location
    New Hampshire
    Posts
    29
    Quote Originally Posted by Ingo View Post
    24" mercury equals 11 psi. Add that to your reading (0-5psi) and you're getting the 14psi boost... So time to ask for your money back on the gauge... your car's fine....
    Thanks Ingo, I had a feeling the car was fine (because I can feel the turbo) and that it was just the gauge. I just wanted to make sure my assumptions were correct before going through the hassle of bringing it back to the dealership. I had it installed before I picked up the car so it'll get taken care of under the warranty thankfully.

  5. #19
    Registered User JaySin's Avatar
    Join Date
    Mar 2008
    Location
    SE Michigan
    Posts
    275
    I, myself, thought about the SPT gauge, but went with the AEM digital gauge ultimately...love it! I especially like the LED marker. Return it and get a different brand.

  6. #20
    Registered User silverschlub's Avatar
    Join Date
    Feb 2012
    Location
    Texas
    Posts
    108
    Quote Originally Posted by JaySin View Post
    I, myself, thought about the SPT gauge, but went with the AEM digital gauge ultimately...love it! I especially like the LED marker. Return it and get a different brand.
    Thats the one I have except I have the black face in it right now. That gauge is teh sex.
    2011 WRX 345WHP/398WTQ E85
    My Build: http://www.clubwrx.net/forums/builds...uild-date.html

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •