2011 WRX sedan audio install, JL audio, eclipse, CDT, Audiocontrol - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

This is a discussion on 2011 WRX sedan audio install, JL audio, eclipse, CDT, Audiocontrol within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Thanks I think I know which one you are talking about. I installed my amp under the drivers and the ...

  1. #16
    Registered User cflip2x's Avatar
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    1,323
    I Support ClubWRX
    Thanks I think I know which one you are talking about. I installed my amp under the drivers and the bolt I used was between the vents under the seat. I am still getting a ground loop noise and will need to recheck the connections.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Hoofhearted's Avatar
    Join Date
    Aug 2011
    Posts
    250
    Quote Originally Posted by cflip2x View Post
    Thanks I think I know which one you are talking about. I installed my amp under the drivers and the bolt I used was between the vents under the seat. I am still getting a ground loop noise and will need to recheck the connections.
    I was getting a very small ground loop noise also and I checked the bolt and came lose so I really cranked it down and the ground loop has been gone sense.

    Also how did you mount your amp? Mine goes amp, carpet, 1/4 wood, foam that I ripped off the underside of the carpet, body of car. Make sure your amp is not touching any metal if it is.

    Sent from my PC36100 using Tapatalk 2
    Last edited by Hoofhearted; 04-16-2012 at 12:57 PM.
    2011 Base WRX

  4. #18
    Registered User cflip2x's Avatar
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    1,323
    I Support ClubWRX
    I took my seat off and moved the amp ground from the drivers floor mat retainer bolt to the bolt between the two vents I believe it was a 13mm. I had the inline filter already grounded to the bolt. I cleared off more paint and primer and tightened it down. It was getting dark out but I did test the should and it appeared to be fine. Once I figured out how to remover the seat warning and airbag connectors it was easy.

    I plan to mount my sub amp on the passenger side. I am thinking about fiber glassing a similar enclosure in each corner for a 12" Kenwood sub that were for my Allante but never got them installed. They have been sitting in storage.

  5. #19
    Registered User 11blackwrx's Avatar
    Join Date
    Sep 2011
    Location
    Akron, OH
    Posts
    1,830
    I Support ClubWRX
    i have the audio integrations box for the hatch, its awesome, love the design of it
    2011 Subaru WRX Premium
    1988 Ford Mustang GT
    2000 Jeep Wrangler TJ

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •