Installed a sub
Results 1 to 7 of 7

This is a discussion on Installed a sub within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I just installed a 10 inch sub to my my 2010 limited hatch. Definitely gave me the low end I ...

  1. #1
    Banned
    Join Date
    Apr 2010
    Location
    Pittsburgh , Pa.
    Posts
    19

    Installed a sub

    I just installed a 10 inch sub to my my 2010 limited hatch.
    Definitely gave me the low end I wanted. Still , the sound is , well , flat. No matter what settings i put treble and midrange. I'm trying not to change the head unit (because I have the media hub and sirius) but from what everyone is saying , changing the HU will solve the problem. any way , what I wanted to ask was , has anyone splurged for audio integrations sub enclosure for the hatcback. Is it worth it ? Is it well made ?
    Any rattles ? Sound good ?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ZJbrandon's Avatar
    Join Date
    Apr 2010
    Posts
    13
    I added a sub to the trunk, then replaced the HU, then replaced the front door speakers. Like you said replacing the HU is popular and will make the stock speakers sound better, but I still thought they were a bit "dull". If you are intent on keeping the HU, I suggest better speakers. Amping them will help even more. I am much happier with the polk replacements, and for the $65 they cost, it was well worth it. Do be aware though you may want to buy or build spacer rings or else cut the stock ones apart to reuse.

    vehicle is a 2010 WRX sedan.

  4. #3
    Registered User bjkeed21's Avatar
    Join Date
    May 2010
    Location
    JC/NB, NJ
    Posts
    53
    hey, this might be a little off topic, but i have a simple 10" sub in a box enclosure with regular speaker wire connections.

    what kind of sub did you install, and how did you connect it?
    2010 WRB WRX 5Door
    Stink-Eye Mob #29

  5. #4
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    i have a stock hu but have 2 10" volfenhag subs and a 1600watt amp... it hits really hard... I turned up the mid and treble and adjusted the amp accordingly and it sounds great...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  6. #5
    Registered User erksplee's Avatar
    Join Date
    Sep 2009
    Location
    PA
    Posts
    124
    I put a 10in JL Audio amp/sub combo thing in my 05 RS a couple months ago. I decided to put a sub in because until that point, I was running a JVC HU with the stock speakers. I got Pioneer speakers on clearance for $40 at Wal Mart (lol) and that completely dropped all bass from my car. So I got the sub and installed it myself. The whole thing sounds really awesome now.

    But to the point; I don't think you're going to be able to change mids and treble without getting a HU at the least. Over time, you're going to want to put in speakers and a HU. I would recommend shopping around for some speakers if you're intent on keeping the stock HU.

  7. #6
    Banned
    Join Date
    Apr 2010
    Location
    Pittsburgh , Pa.
    Posts
    19
    Quote Originally Posted by bjkeed21 View Post
    hey, this might be a little off topic, but i have a simple 10" sub in a box enclosure with regular speaker wire connections.

    what kind of sub did you install, and how did you connect it?
    I put a Pioneer TS-W253R 10 inch sub in a small enclosure that I had left over from an old (piece of crap) sub. I just have it sitting in the back of the hatch. The sub kicks but I'd like to get a custom enclosure to put it in. I like the audio integrations one because it takes up very little space.

  8. #7
    Banned
    Join Date
    Apr 2010
    Location
    Pittsburgh , Pa.
    Posts
    19
    Quote Originally Posted by ralph958 View Post
    I put a Pioneer TS-W253R 10 inch sub in a small enclosure that I had left over from an old (piece of crap) sub. I just have it sitting in the back of the hatch. The sub kicks but I'd like to get a custom enclosure to put it in. I like the audio integrations one because it takes up very little space.
    I bought male /female connectors and wired them together. I tapped wires off of the rear speakers and plugged in the harness to the back of the HU and fed the wires down the console , under my seat to my amp. Tapped into the center console 12 volt socket for power. It's a 30amp line.
    I put a 20amp fuse in line to my amp. Works just fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •