Dash Gauge mount....removed factory clock...Airbag light
Results 1 to 8 of 8

This is a discussion on Dash Gauge mount....removed factory clock...Airbag light within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; So I removed my factory clock because I have a 3 pod dash gauge mount there and the airbag light ...

  1. #1
    Registered User lytlec's Avatar
    Join Date
    Jan 2009
    Location
    Central PA
    Posts
    4,308

    Dash Gauge mount....removed factory clock...Airbag light

    So I removed my factory clock because I have a 3 pod dash gauge mount there and the airbag light now comes on on my instrument cluster...should I just plug the clock back in and shove it under gauge pod?
    <-------- Taylor Swift.
    2006 WRX 330whp. 300wtq. Slow.
    Hawk-Eye Alliance #137
    First Mods...what to do.
    Subaru Guide

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,296
    I Support ClubWRX I Support ClubWRX
    Yeah, I think removing the clock shorts the SRS system somehow and will cause your airbags to not inflate in the case of an accident. I would just leave it hooked up and shove it down in the dash somewhere.

  4. #3
    Registered User lytlec's Avatar
    Join Date
    Jan 2009
    Location
    Central PA
    Posts
    4,308
    Huh...yeah, I guess I should do that! Thanks!
    <-------- Taylor Swift.
    2006 WRX 330whp. 300wtq. Slow.
    Hawk-Eye Alliance #137
    First Mods...what to do.
    Subaru Guide

  5. #4
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,725
    I Support ClubWRX
    +1 that's what i did when i installed my dash pod as well

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  6. #5
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Being that there is an airbag light in the clock area in the 06+, it makes sense that it would cause a problem. Definitely fix that.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  7. #6
    Registered User lytlec's Avatar
    Join Date
    Jan 2009
    Location
    Central PA
    Posts
    4,308
    Well that sucks...cause I hacked up the harness and wired my gauges into there....ha...hmm......
    <-------- Taylor Swift.
    2006 WRX 330whp. 300wtq. Slow.
    Hawk-Eye Alliance #137
    First Mods...what to do.
    Subaru Guide

  8. #7
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,296
    I Support ClubWRX I Support ClubWRX
    Heh, common mistake. You should be able to just splice the wires and run to both.

  9. #8
    Registered User SpAnKy WrX's Avatar
    Join Date
    Dec 2009
    Location
    Central NY
    Posts
    49
    thats weird mine never worked so i just pulled it out yesterday to run my boost gauge wires down. i never got a light. is that a newer suby thing? and i wired my gauge up to my cd players wires.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •