Need Help! 2009 WRX Boost Guage Install - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 23 of 23

This is a discussion on Need Help! 2009 WRX Boost Guage Install within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Originally Posted by Heide264 Fair enough. You did a lot more work than I would have. In my case I ...

  1. #16
    Registered User economatic's Avatar
    Join Date
    May 2009
    Location
    Portland, OR
    Posts
    843
    Quote Originally Posted by Heide264 View Post
    Fair enough.

    You did a lot more work than I would have. In my case I probably would have just stuck tape over it. Forget what the tape is called, it is actually a type of tape used in photography if I remember right. I have a roll of it, and it is a roll of gold in my opinion.

    It's similar to scotch tape, but I use it on things like routers/tv power lights and such to dim the LEDs so they aren't so darn bright.

    Not the right way to fix it sometimes, but it works surprisingly well.

    Kudos, and the install looks real clean =)
    I'd be interested to hear what kind of tape you're talking about. I have my Maddad gauge mounted on the steering column with double sided tape (I've tried a couple different 3M types now) but it eventually comes loose. When the interior of the car gets hot the tape gets gooey.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Jun 2010
    Posts
    82
    Hey man really nice setup with the gauge. I like how clean it is. How did you remove the dash to mount it?

  4. #18
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,365
    I Support ClubWRX
    I made a quick stab at installing mine last year and couldn't for the life of me fish a wire through the firewall- on my 02 and 04 it was a piece of cake, on the 09 it's a piece of $#!+!

    I'm going to give a go again tomorrow (about a year later )- any tips on the firewall routing would be greatly appreciated.

    I like the dimming solution you came up with!

    Mike
    "Simplify and add lightness." - Colin Chapman

  5. #19
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by Big Sky WRX View Post
    I made a quick stab at installing mine last year and couldn't for the life of me fish a wire through the firewall- on my 02 and 04 it was a piece of cake, on the 09 it's a piece of $#!+!

    I'm going to give a go again tomorrow (about a year later )- any tips on the firewall routing would be greatly appreciated.

    I like the dimming solution you came up with!

    Mike
    The firewall doesn't have a grommet on the 09?
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  6. #20
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,365
    I Support ClubWRX
    oh yeah- it's got a grommet- unfortunately the grommet leads to never-never land
    "Simplify and add lightness." - Colin Chapman

  7. #21
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,365
    I Support ClubWRX
    after much cursing, scraped knuckles (and a little praying ) I got the coat hanger through to the interior, everything is ready to go, just need to get power to it- found some little taps for the mini fuses so should be good to go
    "Simplify and add lightness." - Colin Chapman

  8. #22
    Registered User wrx1234's Avatar
    Join Date
    Sep 2009
    Location
    Dover DE
    Posts
    623
    I put a boost guage in about a month ago. My question to you guys is why are you going through the firewall? i went through the left fender and up through the hood. Only had to pop 4 of those plastic screws of holding the wheel well in place. Took me about 1 min to run the line and about 30 - 45 mins total install.

    Picture in this thread:

    http://www.nebraska-subaru.com/forum...p?topic=9203.0

  9. #23
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,365
    I Support ClubWRX
    because that's we've always done it the older Imprezas had a plug that was a direct way into the interior- the 08+'s don't

    yours looks like a lot easier solution
    "Simplify and add lightness." - Colin Chapman

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •