fuel guage don't work
Results 1 to 2 of 2

This is a discussion on fuel guage don't work within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; i have a 03 wrx since i got it the fuel guage don't work don't know i put it on ...

  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    15

    fuel guage don't work

    i have a 03 wrx since i got it the fuel guage don't work don't know i put it on the code reader and it says fuel level sensor high input A what does the mean . i replace the fuel pump and the leveler still don't work i was thinking is my cluster anybody have a idea what could it be .

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jma_1000's Avatar
    Join Date
    May 2007
    Location
    seattle
    Posts
    905
    Quote Originally Posted by lesterwrx03 View Post
    i have a 03 wrx since i got it the fuel guage don't work don't know i put it on the code reader and it says fuel level sensor high input A what does the mean . i replace the fuel pump and the leveler still don't work i was thinking is my cluster anybody have a idea what could it be .
    maybe the cluster plug is loose. jiggle it around and see what happens

    or take your cluster apart and see if anything is amiss.
    "I do well to be angry, even unto death."
    I ♥ rice

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •