CD player wont power on
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on CD player wont power on within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; i recently got a new kenwood cd player, when I first installed it, it was going fine but now I ...

  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    13

    CD player wont power on

    i recently got a new kenwood cd player, when I first installed it, it was going fine but now I am not getting any power through to it.
    I have checked all the necessary cables connecting to it and they are fine, I have been told it could possibly be my alternator but I am just not sure.
    Any help would be greatly appreciated.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    Maybe the unit itself is dead?

  4. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    13
    Hmm yeah it could be but I highly doubt it as it was fading in and out before when it got to a certain volume, Would that be a fuse problem ?

  5. #4
    Registered User kalidas's Avatar
    Join Date
    Jan 2009
    Location
    Tucson, AZ
    Posts
    261
    The symptoms of fuse problems are usually come in the form of: "It was working fine, now it's not." Fuses in my experience don't cause intermittent failures, because once they fry they are done and there is no more circuit. If you have a multimeter, you could check voltages on your incoming power to the unit and that would help narrow it down to the unit or the power source. How long ago did you purchase the head unit? Do you have a warranty on it at all?

  6. #5
    Registered User
    Join Date
    Mar 2009
    Posts
    13
    Ha it's all fixed now, I posted this question for a mate, He just didn't plug it in properly -.-

  7. #6
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    You mean this was a lie?

    Quote Originally Posted by GunWecks View Post
    I have checked all the necessary cables connecting to it and they are fine,
    I feel so betrayed!

  8. #7
    Registered User
    Join Date
    Mar 2009
    Posts
    13
    I'm sorry ! He is extremely incompitent

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •