02 WRX Wagon instrument cluster probs
Results 1 to 1 of 1

This is a discussion on 02 WRX Wagon instrument cluster probs within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; So I am doing the dash instrument cluster color change from green to red. my first attempt was just changing ...

  1. #1
    Registered User cnorm's Avatar
    Join Date
    Oct 2008
    Location
    Kalispell, MT
    Posts
    2

    Red face 02 WRX Wagon instrument cluster probs

    So I am doing the dash instrument cluster color change from green to red. my first attempt was just changing out bulbs but did not get the results i wanted from LED bulbs or incandescents. so i took the cluster apart to see if i could solder in LED's (did in my toyo truck...) well i got it apart just to see if i could easily and did. i put it back together to order lights. well i guess i didn't get the needle in the hole (insert your own pun here) and messed up the coil for the speedo. in turn i got a new dash off ebay. well i tried this again with the new one with success and it looks bad ass. but my tach and speedo stick and jump around a bit, not as smooth as before. i tried oiling the needles shaft but no luck.... anyone else have this prob? I'll get pics of the finished dash tonight to post.
    well it won't let me post cuz i'm new. so maybe later
    Last edited by cnorm; 10-02-2008 at 09:29 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •