No air from vents
Results 1 to 7 of 7

This is a discussion on No air from vents within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; My 03 WRX does not have any air coming from the vents when its on the high setting. I hear ...

  1. #1
    Registered User
    Join Date
    Oct 2005
    Posts
    48

    No air from vents

    My 03 WRX does not have any air coming from the vents when its on the high setting. I hear the blower going strong, but get nothing from the vents. How input on how to get this resolved?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User adizzle02's Avatar
    Join Date
    Mar 2008
    Location
    Sandy Utah
    Posts
    963
    Quote Originally Posted by Z28-WRX View Post
    My 03 WRX does not have any air coming from the vents when its on the high setting. I hear the blower going strong, but get nothing from the vents. How input on how to get this resolved?
    have you had any work done on the car??? almost sounds like something got disconnected behind the center console
    VF39'd and Clark Tuned
    BugEyeMafia #176
    Basshead Member #3

  4. #3
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    So the fan is running but it's not blowing any air? There must be a blockage then. Maybe your cabin air filter is so dirty it's totally clogged?

  5. #4
    Registered User
    Join Date
    Oct 2005
    Posts
    48
    It happen during a rain storm and little by little the air flow from the vents was getting low. The blower motor is working strong. How do i check the cabin filter?

  6. #5
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    Quote Originally Posted by Z28-WRX View Post
    How do i check the cabin filter?
    Take it out and look at it. It's located behind the glove box. I doubt that is the problem, but couldn't hurt to check I guess.

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    do you have any air coming out at all...i.e..if you move the selector to defrost does anything come out the defrost vents? does anything come out the floor vents?

  8. #7
    Registered User
    Join Date
    Jul 2008
    Posts
    21
    I just had the same problem.

    its really humid today and I had the air on but accidentally had the selector on fresh air and I noticed that the air was barely coming out even on 4. so I took the glove compartment out and checked the filter. well there wasnt one. someone took it out. by this time I restarted the car and it blew hard. so I guess that the moisture turned to ice on the coil and blocked the airflow.

    lesson is if its moist out leave it on recirculate. it works better anyway.
    2002 wagon stock auto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •