guesses, guesses anyone?
Results 1 to 6 of 6

This is a discussion on guesses, guesses anyone? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I recently purchased a WRX, and one of the things I noticed on the first test drive is when you ...

  1. #1
    Registered User
    Join Date
    Nov 2007
    Location
    Iowa City, IA
    Posts
    41

    guesses, guesses anyone?

    I recently purchased a WRX, and one of the things I noticed on the first test drive is when you try to roll UP the passenger rear window, it makes an electrical popping sound. It only does it when trying to go up, and only does it from the driver's side window switch, it does not do it from the window switch on that door. Also, upon closer inspection and a little more thinking, it sounds like it's coming from the speaker of the passenger rear door ( where the window doesn't work).... also, the window doesn't work from either switch.

    anyways, I haven't torn into it yet, but I thought I'd see what some guesses were on what might be going on here.


  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Nov 2007
    Location
    SE PA
    Posts
    42
    at the very least you have a short I'm guessing. Does the speaker actually play or no?

  4. #3
    Registered User
    Join Date
    Nov 2007
    Location
    Iowa City, IA
    Posts
    41
    yes, the speaker still plays normally!

  5. #4
    Registered User
    Join Date
    Nov 2007
    Location
    Iowa City, IA
    Posts
    41
    Okay, so I was putting new speakers in the front of the WRX yesterday, and was taking a part the drivers side door when I got to thinking....
    1) will the window work from the passenger side switch when the drivers side switch is disconnected?
    Answer, No....
    2) If the switch on the drivers door is disconnected, does the speaker still play?
    answer is NO, WTF????

    so I got to the passenger rear door and pulled the panel off just out of curiosity to see what I could find. I found two newer wires running the speakers in that door, with everything else in apparently good condition, except for a wiring plug that was hacked off leaving two wires cut. I assume these were for the speakers, since everything else was mated up with it's respective plug. One of the two cut wires had power, however I forgot to check the other for ground..... I tried touching each to it's respective post on a speaker and it didn't run power. I then pulled all of the wires out through the door and into the car by the passenger front seat, and found nothing of interest. I plan on tearing the CD changer out this weekend to see if I find anything else.
    Let me know if you have any ideas or suggestions, just thought I'd give a quick update.
    Thanks!
    Last edited by stickyfeet; 12-17-2007 at 04:30 PM.

  6. #5
    Registered User
    Join Date
    Nov 2007
    Location
    SE PA
    Posts
    42
    Drivers side switch removed cuts out the windows in all the cars...it's a master switch that needs to be in place.

    As to the second part...sounds like whoever owned your car before you hacked the living crap out of the harnesses.

  7. #6
    Registered User
    Join Date
    Nov 2007
    Location
    Iowa City, IA
    Posts
    41
    well, I pulled the cd changer and center console out today and found nothing... so I started back at the Passenger rear door and started heading towards the cd player. I pulled out the plastic trim pieces and the carpet up a bit heading towards the front of the car....
    Right about mid way through the passenger front door area I came across two wires that had been cut, and the red and black speaker wires had been spliced in.
    here's what I found....
    From the factory you've got:
    -Red/White wire is ground for both the right rear power window motor, AND the right rear speaker.
    -Blue/White wire is power for the Up portion of the passenger rear window switch
    -Blue/Yellow is the power for the right rear door speaker....

    The Red/White wire and the Blue/White wire were both cut ( the Red/White and the Blue/Yellow should have been cut to run new wires for the passenger rear speaker, so they must be color blind too?)....
    They then connected two new wires ( a black and a red wire) to these. They connected Red/White to the Red wire, and the Blue/White wire to the Black wire.... Not only is this part the opposite of the way it should have been with the way they had it hooked up, but they also crossed some wires while doing so.
    They had ground running the "power" side of the speaker ( which doesn't matter really, it will still play sound, it just won't be right), but they were also running power from the driver's window switch through the ground side of the speaker.
    Since the red and white wire apparently splits somewhere AFTER where they had cut it, there was no longer any ground to the Passenger rear window motor...
    What a bunch of geniuses

    And here's what's really pathetic.... they did this for NO real reason that I can think of. All of the wires were intact from the splice point into the door with no shorts or anything. All I had to do was reconnect the proper colors to each other, pull out the added wires, and put two new connectors that plug onto the speaker, WTF???
    Quote Originally Posted by Trainrex View Post
    I didn't know they built an FMIC on junkyard wars.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •