08 Impreza'a in dash factory Nav/DVD system
Results 1 to 7 of 7

This is a discussion on 08 Impreza'a in dash factory Nav/DVD system within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Hi everyone, I am the proud new owner (3 days) of a 08 Impreza, nicely loaded. Drives great, looks great... ...

  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    2

    08 Impreza'a in dash factory Nav/DVD system

    Hi everyone, I am the proud new owner (3 days) of a 08 Impreza, nicely loaded. Drives great, looks great... I would like to know if anyone knows the model number for the Kenwood in dash Nav system that Subaru puts in the Impreza. I know the illegality of it, but maybe someone could help me with directions on properly and safely bypassing the video shut-off from the Break, or is there a setup code to the system that can be easily accessed. My 15 yr old son and I go on long trips, and it would be nice for him to watch a movie or play a game while I drive.

    Thanks for any help.
    Scott

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User tom'sti's Avatar
    Join Date
    Feb 2007
    Location
    Reality
    Posts
    1,381
    hehe, yeah none of us here mod our cars beyond legalities!

    Not sure about the new WRX but on some others i've installed, its just a wire the picks up the parking brake switch signal, correct? Disconnect that and you're golden. BTW, watch yourself move through a nav world is far more distracting than a movie.
    Whoever appeals to the law against his fellow man is either a fool or a coward. Whoever cannot take care of himself without that law is both. For a wounded man shall say to his assailant,"If I live, I will kill you. If i die, you are forgiven. " such is the rule of Honor.

  4. #3
    Registered User Spincycle's Avatar
    Join Date
    Jul 2007
    Location
    Janesville, WI
    Posts
    324
    I have had two Kenwood NAVI decks, both would not play movies while driving unless you grounded the wire that goes to the parking break. Simply removing it will not solve the issue, you need to ground it, then you'll be all set. Good luck!

  5. #4
    Registered User tom'sti's Avatar
    Join Date
    Feb 2007
    Location
    Reality
    Posts
    1,381
    Right, thats what i meant. Its been a while.
    Whoever appeals to the law against his fellow man is either a fool or a coward. Whoever cannot take care of himself without that law is both. For a wounded man shall say to his assailant,"If I live, I will kill you. If i die, you are forgiven. " such is the rule of Honor.

  6. #5
    Registered User
    Join Date
    Nov 2007
    Posts
    2

    Here is the problem

    I have never done anything like that before, so I would need good directions, or a manual.. Sorry I am a messed up Catholic school boy who had "Jesus shop" not "auto shop" so maybe I'm screwed...

  7. #6
    Registered User nycmedic3722's Avatar
    Join Date
    Oct 2007
    Posts
    5
    chk this posting it was stated above ground the wire works fine did mine about 1 month ago
    http://forums.nasioc.com/forums/show....php?t=1375946

  8. #7
    Registered User jeffmm06's Avatar
    Join Date
    Sep 2007
    Location
    Sacramento, CA
    Posts
    2,138
    Quote Originally Posted by scottd67 View Post
    I have never done anything like that before, so I would need good directions, or a manual.. Sorry I am a messed up Catholic school boy who had "Jesus shop" not "auto shop" so maybe I'm screwed...
    jesus shop....nice
    2005 WRB WRX "was" STAGE 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •