More Suby woes....
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on More Suby woes.... within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; It seems that my 03 WRX is just becoming and endless stream of problems, from the boost control system, to ...

  1. #1
    Registered User
    Join Date
    Jul 2007
    Location
    Ellicott City, MD
    Posts
    41

    More Suby woes....

    It seems that my 03 WRX is just becoming and endless stream of problems, from the boost control system, to detoniations, and now there is no backlight for the instrument cluster. The needles, boost gauge and all other parts light up when I turn the headlights on, and only the gauge cluster stays dark. I flipped the dimmer a few times, but the backlight won't turn on. I can probably fix this, but I'm not sure where to start looking, as I'm not familiar with the electrical system of this car. So, if anyone could point me to a few possible problem locations, that would really help.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User kiger0183's Avatar
    Join Date
    Oct 2005
    Location
    SLC, Ut
    Posts
    617
    check the fuses first. If they're ok, your light has burnt out. You can be brave and take it apart to replace the light.

    GL!
    Stage II and loving it!

  4. #3
    Registered User
    Join Date
    Jul 2007
    Location
    Ellicott City, MD
    Posts
    41
    Update: so I dropped this off at a dealer, turns out the previous owner had installed an aftermarket dash (it changed colors too! can't believe I didn't know about that) that went bad. To replace it is $960 with the same part. I can't find a breakdown of all the dash parts with part numbers, anyone have one/know where to find one?

  5. #4
    Registered User Weedy's Avatar
    Join Date
    Nov 2003
    Location
    Lincoln, NE
    Posts
    188
    I would suggest looking for someone that is sellin their OEM cluster, or you could even spring for an '04 STi cluster for about 1/2 the cost. Or maybe even find a JDM '02-'03 STi cluster. You can get one of those much cheaper than what the stealership is quoting you. If your cluster is borked this is what I would suggest. Otherwise the stealership is RAPING you with no vaseline on that cluster to replace it. Just have them put it back together, pay them for their troubleshooting fee and walk away.

  6. #5
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    F all that. Get in there a find out what was done. There is plenty of info out there to get yours working again 200%

  7. #6
    Registered User Damien02WRX's Avatar
    Join Date
    Dec 2005
    Location
    California City, CA
    Posts
    441

  8. #7
    Geriatric Ginger Mod Rogan's Avatar
    Join Date
    May 2007
    Location
    behind the wheel
    Posts
    8,188
    I Support ClubWRX
    Quote Originally Posted by Seanohue View Post
    Update: so I dropped this off at a dealer, turns out the previous owner had installed an aftermarket dash (it changed colors too! can't believe I didn't know about that) that went bad. To replace it is $960 with the same part. I can't find a breakdown of all the dash parts with part numbers, anyone have one/know where to find one?
    Back the F up... 960$ for (basically) indiglo gauges? WTF evAr..
    Got a picture? If it is, indeed, indiglo gauges, pull the cluster, remove the overlay crap, and put new bulbs in the cluster, OE-style.
    Rogan o_0
    '96 Dodge 2500 CTD @ 40psi - over 700 lb/ft TQ, 7" stack, and 5speed! - SOLD
    '01 Dodge 2500 CTD 6-holed hand-shaker - 3850# dual disk - 900 lb/ft - SOLD
    '97 Dodge 3500 CTD DUALLY built Auto - 40psi boosties - 750 lb/ft

  9. #8
    Registered User
    Join Date
    Jul 2007
    Location
    Ellicott City, MD
    Posts
    41
    Awesome thanks. I will see what this place comes up with tomorrow and if its outrageous I will just have to find a way to do this myself.

  10. #9
    Registered User
    Join Date
    Jul 2007
    Location
    Ellicott City, MD
    Posts
    41
    Quote Originally Posted by bchslap View Post
    Back the F up... 960$ for (basically) indiglo gauges? WTF evAr..
    Got a picture? If it is, indeed, indiglo gauges, pull the cluster, remove the overlay crap, and put new bulbs in the cluster, OE-style.
    They said it was a rheostat that was messed up. It was the rheostat to change the colors though. I can probably get hold of a soldering iron here if I could source the part for the rheostat. And no, sorry no pics. Car is at the shop.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •