EGT Gauge died.
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on EGT Gauge died. within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; My EGT gauge went dead the other night. I believe everything else is in order, any thoughts on what might ...

  1. #1
    Registered User
    Join Date
    Aug 2003
    Posts
    60

    EGT Gauge died.

    My EGT gauge went dead the other night. I believe everything else is in order, any thoughts on what might have happened? The week before it died, it was not giving steady reading -- it would go on off until it died.

    Thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    have you taken a look at the wiring? its quite possible you have frayed or broken the wire. the wire runs from back to the front of your engine bay. you may have pinched the wire while jacking up the car or something. just a thought. give it a look a lemme know.

    -mike
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  4. #3
    Registered User
    Join Date
    Aug 2003
    Posts
    60
    Thanks for the input. The wire does not look pinched. However, there is a tight pinch before the probe, but that's been there since day 1.

  5. #4
    Registered User uncle lewie wrx's Avatar
    Join Date
    Oct 2004
    Posts
    4,936
    Who makes it?
    06 Aspen White STi w/ Gold BBS's

  6. #5
    Moderator MidKnight's Avatar
    Join Date
    Oct 2002
    Location
    Bergen, NJ
    Posts
    4,711
    I Support ClubWRX
    It's probably just the probe that's dead. That's not uncommon. Get a new probe. Most vendors that sell the gauge (whatever gauge it is) will probably be able to get you a new probe...
    '03 WRX
    '01 2.5RS
    MODS | PICS | Dyno
    "Stuff sold by the gram is always going to be more exciting than stuff sold by the pound." - Jeremy Clarkson

  7. #6
    Registered User
    Join Date
    Jul 2004
    Location
    elk grove ca
    Posts
    925
    maybe ur egts got so high u melted that SOB(sensor).. serisouly i have no idea
    14.160@96.011
    90 degree weather
    airhog, removed silencer, and removed stock catback exhaust (stock DPs in place) and craptacular california 91 octane piss water

  8. #7
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    Quote Originally Posted by MidKnight
    It's probably just the probe that's dead. That's not uncommon. Get a new probe. Most vendors that sell the gauge (whatever gauge it is) will probably be able to get you a new probe...
    +1... i think way too much.
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  9. #8
    Registered User 04blkWRX's Avatar
    Join Date
    Jul 2003
    Location
    NNJ
    Posts
    721
    Yeah you can usually get a new probe but I think in many cases the probe is the most expensive part of the whole deal...

    If it was going "on and off" is sounds like it could be a bad connection, maybe the power source, maybe the ground. Maybe a broken wire right at the sensor. Check your connections first if you can, you might save yourself a chunk of change.
    06 S40 T5 AWD
    Previous: 2004 WRX
    05 CBR600F4i

  10. #9
    Registered User
    Join Date
    Aug 2003
    Posts
    60
    Thanks. It is an autometer EGT gauge. I started looking at probe costs and they do seem a little pricey. I'll take a look at the connections and probe this weekend.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •