Passport 8500 Radar Detector Install
Results 1 to 9 of 9

This is a discussion on Passport 8500 Radar Detector Install within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Just installed my radar detector this afternoon, thought I'd post a couple of pics. I disassembled the smartcord thing and ...

  1. #1
    Registered User
    Join Date
    Sep 2005
    Posts
    33

    Passport 8500 Radar Detector Install

    Just installed my radar detector this afternoon, thought I'd post a couple of pics. I disassembled the smartcord thing and took out the lights and switch and mounted them into a spare switch blank in the dash over by where the fog light switch is (2005 WRX). Then I just wired the power into an accessory line and then routed the cord up the a-pillar and under the headliner over to the radar.

    Photos at http://photos.friode.net/v/Miscellaneous/vroom/radar/

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User aznburn210's Avatar
    Join Date
    Mar 2005
    Location
    Austin,TX
    Posts
    521
    nice man.. you shold of put the rada above the rear view miror so you wouldnt see itwell thats wher ei would have put it. but looks good man

  4. #3
    Registered User
    Join Date
    Sep 2005
    Posts
    33
    I thought about that - I might move it around. There's plenty of cable and it's still just held on by suction cups.

  5. #4
    Registered User WTypeRogerX's Avatar
    Join Date
    Feb 2003
    Location
    Denver, CO
    Posts
    2,486
    Quote Originally Posted by Firebug24k
    Then I just wired the power into an accessory line and then routed the cord up the a-pillar and under the headliner over to the radar.

    Photos at http://photos.friode.net/v/Miscellaneous/vroom/radar/
    Your link doesn't work: Error (ERROR_MISSING_OBJECT)

    Can you fix it? I was just going to hard-wire mine in since I'm sick of the visible coiled cord going down the middle of my windshield and console and the torque of the cable pulling out of the socket and loosing power on it. But I'm not sure exactly how to wire into the fusebox.
    2005 World Rally Blue WRX Sportwagon
    Biatch totalled my 2002 WRB WRX Sportwagon
    I miss my bugeye.
    Image is nothing, performance is everything. All your rice be ownz by us.
    If you're not going to spend your money on women or alcohol, you might as well spend it on cars.

  6. #5
    Registered User WRX88's Avatar
    Join Date
    Dec 2005
    Location
    New Jersey
    Posts
    1,304
    I just got mine hardwired today. I paid $20 to have it done. If i have a chance, I'll take some pics of the wiring.

  7. #6
    Registered User Needles's Avatar
    Join Date
    Nov 2002
    Location
    Long Island N.Y.
    Posts
    305
    Quote Originally Posted by WTypeRogerX
    Your link doesn't work: Error (ERROR_MISSING_OBJECT)

    .
    Yea no pics

    Stg 2 06STI
    02/04 WRX MSPT Tuned - 18g(DEAD)

    "Never go in against a Sicilian when death is on the line!"-Vizzini

  8. #7
    Registered Whippersnapper mustangtx63's Avatar
    Join Date
    Mar 2005
    Location
    CS, TX
    Posts
    4,884
    Quote Originally Posted by WTypeRogerX
    Your link doesn't work: Error (ERROR_MISSING_OBJECT)
    ~ Retired Blobeye Syndicate #063 ~
    2011 Ford F-150 ECOBOOST 4x4

  9. #8
    Registered User
    Join Date
    Sep 2005
    Posts
    33
    Wow, this thread is back from the dead. Here's the updated link to the pictures:

    http://photos.friode.net/v/vroom/radar/

  10. #9
    Registered User WRX88's Avatar
    Join Date
    Dec 2005
    Location
    New Jersey
    Posts
    1,304
    damn thats clean. I have the smart chord sticking out of the hole in the foglight blank. I'll have to try and make it look clean like yours.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •