Got a surprise when I installed my S203 Hazard button - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

This is a discussion on Got a surprise when I installed my S203 Hazard button within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; thats pretty sweet....i love the seats...

  1. #16
    Registered User WRXcelration's Avatar
    Join Date
    Apr 2004
    Location
    Allentown PA
    Posts
    2,797
    thats pretty sweet....i love the seats
    05 STI

    Speed Comes At A Price...How Fast Can You Afford To Go?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Skreekin's Avatar
    Join Date
    May 2005
    Location
    Bellingham, WA
    Posts
    1,582
    Quote Originally Posted by Family Guy
    The triangle in the middle lights up when the headlights are on! The USDM doesn't do that.
    Neato!
    hmmm, am I special then or did Subaru make the 2005 with the glowing hazard light a standard feature? I only say this cause mine is back lit too.

  4. #18
    Registered User E-Wrex's Avatar
    Join Date
    May 2005
    Location
    Portland
    Posts
    720
    Yeah, is that thing in your DIN a stereo or gauges, it looks freakin rad with that gague pod above it. I hate U.S. import laws, I want an S203
    My poor tranny!... someone sell me an aspen white 06 sti.

    Mods

  5. #19
    Registered User VpointVick's Avatar
    Join Date
    Aug 2005
    Location
    Charlotte
    Posts
    12
    Quote Originally Posted by Skreekin
    hmmm, am I special then or did Subaru make the 2005 with the glowing hazard light a standard feature? I only say this cause mine is back lit too.
    +1 for backlit '05

  6. #20
    Registered User IDAFC21's Avatar
    Join Date
    May 2004
    Location
    Avondale, AZ
    Posts
    1,386
    i have an 02 w/ a backlit hazard button i wasnt aware there were any that were not. then again subaru is wierd like that. 02's dont have the glowy ring around the ignition that everyone else has

  7. #21
    Registered User
    Join Date
    Jun 2005
    Location
    Hong Kong
    Posts
    22
    Quote Originally Posted by E-Wrex
    Yeah, is that thing in your DIN a stereo or gauges, it looks freakin rad with that gague pod above it. I hate U.S. import laws, I want an S203
    that is a stereo system by Sony.....
    S203 312/555

  8. #22
    Registered User Rice Boi's Avatar
    Join Date
    Dec 2001
    Location
    WA
    Posts
    286
    I'll second that as well, the stock one also lights up, I'm sure that yours just burned out. Mine burned out and I just replaced it with a S202 one as well.
    HKW

  9. #23
    Registered User IDAFC21's Avatar
    Join Date
    May 2004
    Location
    Avondale, AZ
    Posts
    1,386
    Quote Originally Posted by Rice Boi
    I'm sure that yours just burned out.
    thats probably the case, hell a couple weeks ago i just realized the glove compartment has a light in it! it hasnt worked since i bought the car. haha

  10. #24
    Registered User Family Guy's Avatar
    Join Date
    Jul 2003
    Location
    Memphis TN
    Posts
    982
    Guess thats it, sorry for the confusion.
    Now: 04 WRB STi (stock)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •