I've been getting a slight gasoline smell in my cabin..?bad?
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on I've been getting a slight gasoline smell in my cabin..?bad? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I noticed the past 2 days a very faint smell of gasoline in my cabin when i ran the AC ...

  1. #1
    Registered User
    Join Date
    Jun 2005
    Location
    Massachusetts
    Posts
    66

    I've been getting a slight gasoline smell in my cabin..?bad?

    I noticed the past 2 days a very faint smell of gasoline in my cabin when i ran the AC and when i defogged this morning. I haven't gassed up since last monday(full), and am at about a 1/2 tank. My car is only about 5 months old... what could it be?... its never happened before.......

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jun 2005
    Location
    South Dakota
    Posts
    632
    You probably have a leak in one of your lines. Probably in a connection to the fuel rails. Open the hood and check if the leak is near an exhaust pipe, manifold, or turbo. If it is, you stand a good chance of going up in flames. If you can safely drive it, take it to the dealer immediately. If you can't safely drive it make them come and get it.

  4. #3
    Registered User
    Join Date
    Jun 2005
    Location
    Massachusetts
    Posts
    66
    hmmm. I've checked everything under the hood. everything is dry as a bone, and no spillage at all under the car.......

  5. #4
    Registered User
    Join Date
    Sep 2005
    Location
    Central NJ
    Posts
    220
    gasoline won't have obvious markings or anything because it does evaporate pretty quickly. unfortunately, you may have to have the car running, and have someone rev the car a few times. either way, take it to the dealer.

  6. #5
    Registered User WRXDriver82's Avatar
    Join Date
    Jul 2005
    Location
    Norwich, CT
    Posts
    743
    I've read a thread on www.scoobymods.com about the same problem. They found it was a gas leak near the intake manifold I believe... try doing a search on there with "gas leak" as your search request. And yes, they could only find the leak when the car was running.

  7. #6
    Registered User Cheveyboy's Avatar
    Join Date
    Feb 2003
    Location
    Charlotte NC
    Posts
    409
    There is a TSB for it, depending on year i think it only effects 02's. I have had this problem. There are alot of threads on this topic on Nasioc's website.
    Will #1
    LISC #2

  8. #7
    Registered User iMP|2EZiONS's Avatar
    Join Date
    May 2004
    Location
    Colorado Springs/Boulder, Colorado
    Posts
    1,510
    This only happens to me on really cold mornings. All I do is turn the air to recirculate and the smell dissipates. But in your case I'm not really sure, especially if its not that cold where you are yet.
    2005 CGM STi

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •