I just got my autometer gauges in:
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on I just got my autometer gauges in: within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; tell what you guys think. btw, they're oil press and boost gauges....

  1. #1
    Registered User extraducksauce's Avatar
    Join Date
    Jun 2002
    Location
    Cal State Long Beach, or with your mom
    Posts
    125

    I just got my autometer gauges in:

    tell what you guys think.
    btw, they're oil press and boost gauges.
    Attached Thumbnails Attached Thumbnails 01.jpg  
    Peace
    EDS

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User extraducksauce's Avatar
    Join Date
    Jun 2002
    Location
    Cal State Long Beach, or with your mom
    Posts
    125
    another
    Attached Thumbnails Attached Thumbnails 02.jpg  
    Peace
    EDS

  4. #3
    Registered User extraducksauce's Avatar
    Join Date
    Jun 2002
    Location
    Cal State Long Beach, or with your mom
    Posts
    125
    here are some more of my car pictures:

    CLICK HERE



    what do you guys think?
    Peace
    EDS

  5. #4
    Registered User is2scooby's Avatar
    Join Date
    Jun 2002
    Location
    Honolulu, HI
    Posts
    4,234
    Nice! Is that the Autometer pod? How's the fit/finish?
    Aloha, Richard...
    Retired Moderator
    TXS Stage 4 UTEC + TMIC + JoeP
    12.75 @ 105.67mph - 1.74 60'

  6. #5
    Registered User extraducksauce's Avatar
    Join Date
    Jun 2002
    Location
    Cal State Long Beach, or with your mom
    Posts
    125
    is2scooby
    yes, it is the autometer dual gauge pod. i spoke to an autobody painter and said not to get it painted. he said that since the pod was textured, there wouldnt be a way to prepare (e.g., sand) it well enough, and it would end up looking like crap (e.g., it would chip). anyhow to make a short story long, i left it black, it sits perfectly flush against the a pillar, and the gauges are perfectly tilted toward the driver (not like the lotek ones). i love'm.
    Peace
    EDS

  7. #6
    Registered User QuickSilver's Avatar
    Join Date
    Jul 2002
    Location
    Bay Area, CA
    Posts
    1,294
    I like the look of them too. Looks to be a clean install and matches the OEM well. Sharp!

    So the pod is placed directly over the current pillar, right? Did you tape or screw the pod on?
    Can you enlighten me on how the oil pressure sending unit install went? I hear alot about boost and EGT, but never see much on the other gauges. i'm aiming for boost, EGT and oil pressure.

    Thanks.
    '02 Plat. Wagon, Manual

  8. #7
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    yeah autometer guageworks are nice. i have the a-pillar with 3 gauge places. it fits like a dream, i screwed it in with the plastic screws that were provided.... it fit right over the stock a-pillar.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  9. #8
    Registered User extraducksauce's Avatar
    Join Date
    Jun 2002
    Location
    Cal State Long Beach, or with your mom
    Posts
    125
    quicksilver,

    to quite honest with you i'm an electrical retard. i had iSR install them for me, and i had them screw them in. the replacement apillar costs only $80.00. the screws keep the a pillar pod absolutely secure.

    the black plastic doesn't stand out either, if you were wondering about that too. you really have to be extremely critical with the car's interior really notice.
    Peace
    EDS

  10. #9
    Registered User QuickSilver's Avatar
    Join Date
    Jul 2002
    Location
    Bay Area, CA
    Posts
    1,294
    Thanks.
    I haven't touched my electrical systemes yet...so I don't know how difficult it will be. I have zero experience, but am willing to give it a go. I intend to do a lot more to this car and I can't afford the labor charges...so might as well learn.
    '02 Plat. Wagon, Manual

  11. #10
    Registered wrxinthehouse's Avatar
    Join Date
    Nov 2001
    Location
    awdpirates.net
    Posts
    3,086
    I have the same pillar pod with EGT and Boost in mine. Looks/fits great.


    Mine's grey though No chips either.

  12. #11
    Registered User droidel's Avatar
    Join Date
    Aug 2002
    Location
    Syracuse, NY
    Posts
    63
    I used to redo car interiors, and that including painting and repainting alot of plastics. There are alot of solvents that would take the black finishing coat off, so sanding would be unneccessary. I don't understand why he would have told you not to get it painted. If you want it to be painted, you could probibly get it done for $75 professionally.
    Wanna go for a ride?!

  13. #12
    Registered wrxinthehouse's Avatar
    Join Date
    Nov 2001
    Location
    awdpirates.net
    Posts
    3,086
    Or you could get custom spraypaint made up for $10 and use lots of coats.

  14. #13
    Registered User Nexus6's Avatar
    Join Date
    Jun 2002
    Location
    O.C., Ca
    Posts
    1,748
    looking good there, keep up the good work
    La Fee Verte
    Subaru 2002 Impreza WRX Sedan

  15. #14
    Registered User QuickSilver's Avatar
    Join Date
    Jul 2002
    Location
    Bay Area, CA
    Posts
    1,294
    So let me get this straight: the Autometer ones are supposed to be installed over the OEM pillar and the Lotek pillars replace the OEM?

    That said, only the Lotek have an exact match for the Wagon?

    Did lotek fix the "angle problem" previously mentioned in another thread?

    Sorry for the Q's but I want to be clear.
    '02 Plat. Wagon, Manual

  16. #15
    Registered wrxinthehouse's Avatar
    Join Date
    Nov 2001
    Location
    awdpirates.net
    Posts
    3,086
    Yep,
    Autometer = over stock a-pillar
    Lotek = replacement

    As far as I know, Lotek has not changed the angle of their pods. Most people who have it says it doesn't bother them though. I think your only choice for the wagon is Lotek.

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •