A/C ? on 2005 WRX
Results 1 to 15 of 15

This is a discussion on A/C ? on 2005 WRX within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I notice the temperature of the air coming out varies drastically, from cooler than the outside air to FRIDGID, no ...

  1. #1
    Registered User
    Join Date
    May 2005
    Posts
    11

    A/C ? on 2005 WRX

    I notice the temperature of the air coming out varies drastically, from cooler than the outside air to FRIDGID, no matter what temperature you set. I'm in manual mode. If the temperature setting is higher, the FRIDGID air comes out less often. My Honda's never did this, they just put out air at a steady temperature all the time depending on what the temperature setting was.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User RHONE's Avatar
    Join Date
    Jun 2005
    Location
    whittier
    Posts
    85
    ac units on subaru just don't seem to work right my car hates the ac it automatically shuts the ac off and rolls down the windows. as for the honda you are way cooler in your WRX there is a lot of things your honda won't do that your WRX will do.

  4. #3
    ClubWRX.net Vendor
    Join Date
    Mar 2004
    Location
    Los Angeles
    Posts
    494
    Except climate control and V-tec. I noticed that too.... thought I was low on freon or something. Nope, just a badly designed A/C unit. At least they spent money on the motor and drivetrain.
    Those fools, EVO vs. STi??? That's like comparing ....wait a minute...there's no comparison. The Suby's still working!!! The evo...well... I hope he got the extended warranty.

  5. #4
    Registered User WShade's Avatar
    Join Date
    Nov 2004
    Location
    San Antonio, TX
    Posts
    287
    Quote Originally Posted by scrawshaw
    I notice the temperature of the air coming out varies drastically, from cooler than the outside air to FRIDGID, no matter what temperature you set.
    Same here. I will more than likely take it in before I swap my turbo just to have it on the service record. Although, I know they will tell me nothing is wrong.

    <<-- life begins and ends at 180 mph - CBR 1000RR


    MODS

  6. #5
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Yea it can get pretty cold, fast. I try to use a/c as little as possible.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  7. #6
    Registered User
    Join Date
    Aug 2003
    Location
    Norway, Europe
    Posts
    1,267
    I never had any problem with this on my edm wrx.. Works good, but not anymore..
    Since I "never" use it. I removed it and saved both weight and space
    Silver -02 Impreza WRX

  8. #7
    Registered User dancing_bear's Avatar
    Join Date
    May 2005
    Location
    Chicago, North Side
    Posts
    87
    I have been using the AC on my 05 WRX wagon pretty regularly and it seems to work just fine. I have noticed, like some other cars I have had, that when you go around corners, the cold air can seem to slosh around all of a sudden making you feel cooler or warmer.

    The WRX also seems to have the same AC/heater control unit as a 350Z. The knobs are just enough different to match the interior, but all the controls have exactly the same logos, lights and features.

  9. #8
    Registered User bigwrxguy's Avatar
    Join Date
    Jul 2004
    Posts
    1,306
    I have this same problem it cycles on and off. I took it to the dealer twice now. First time they recharged it. Now this time they found a relay switch that looked bad. He said he cleaned it up and it ran better. But low and behold it's even worse now, it completely turned off and then started making a clunking sound? They are going to order a new relay switch from Japan and see if that works.

  10. #9
    Registered User mykedude's Avatar
    Join Date
    Mar 2004
    Location
    Queens NY
    Posts
    1,331
    Quote Originally Posted by dancing_bear
    The WRX also seems to have the same AC/heater control unit as a 350Z. The knobs are just enough different to match the interior, but all the controls have exactly the same logos, lights and features.
    Great observation! It got me thinking too and so I ran a search and found this:

    my STi is powered by Nissan


    ~myke
    ::2004 JBP WRX::

  11. #10
    Registered User medic's Avatar
    Join Date
    Jan 2005
    Location
    N. Central FL
    Posts
    85
    Also, if you go wide-open on the throttle I think it cuts off the compressor briefly so you get more power, and the air gets warmer for a few moments.

  12. #11
    Registered User DjMestizo's Avatar
    Join Date
    Sep 2004
    Location
    boulder, colorado
    Posts
    72
    Yeah my A/C bogs my car down so bad!!!...I hate using the A/C, plus my hair looks sooooooo much cooler when the wind hits it, chicks dig that.

  13. #12
    Registered User
    Join Date
    Jun 2005
    Location
    east northport ny
    Posts
    153
    when i bought my car it didnt work at all the ac

    i took it in and it was a faulty o-ring that leaked all the refridgerent out.

    but i thave noticed after getting it fixed that it does what you describe, even if i set it at 65 it goes from ice cold to not so ice cold.. hey at least it works now though.. drive homes were leaving me a little swampy
    oops

  14. #13
    Registered User WShade's Avatar
    Join Date
    Nov 2004
    Location
    San Antonio, TX
    Posts
    287
    I want to see pics of the Vega.....................

    <<-- life begins and ends at 180 mph - CBR 1000RR


    MODS

  15. #14
    Registered User
    Join Date
    Jun 2005
    Location
    east northport ny
    Posts
    153
    Quote Originally Posted by WShade
    I want to see pics of the Vega.....................


    http://www.beefhole.com/jeff/vegaf.JPG

    big one

    http://www.beefhole.com/jeff/vega1.JPG

    i cant remember the other file names ive got up there
    Last edited by longislandwrx; 07-01-2005 at 06:13 AM.
    oops

  16. #15
    Registered User WShade's Avatar
    Join Date
    Nov 2004
    Location
    San Antonio, TX
    Posts
    287

    <<-- life begins and ends at 180 mph - CBR 1000RR


    MODS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •