Anyone had a bad gas gauge?
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Anyone had a bad gas gauge? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Ok i just bought the car two weeks ago so i am not terribly familiar with it. I just filled ...

  1. #1
    Registered User Entropy's Avatar
    Join Date
    Nov 2004
    Location
    Northwest MT/ Calgary AB
    Posts
    23

    Anyone had a bad gas gauge?

    Ok i just bought the car two weeks ago so i am not terribly familiar with it. I just filled up the car after it was on E and it took 11.3 gallons...Dont all WRX's have a 15.9 gallon tank??? What gives? Could explain what i though was the horrible gas mileage!!!! I'm missing nearly 1/3 of the tank!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ynotajb's Avatar
    Join Date
    Sep 2004
    Location
    mmmm,, tater salad
    Posts
    2,711
    maybe you still had 4.6 gallons left? just a thought ... never heard of a faulty gas-o-meter
    dude one time i tried to put the trailer bully into the coiler, and I got all messed up

  4. #3
    Registered User Entropy's Avatar
    Join Date
    Nov 2004
    Location
    Northwest MT/ Calgary AB
    Posts
    23
    I am sure i did have that much left, but the gas gauge in the car was reading below E. Maybe it became "uncalibrated"???

  5. #4
    ClubWRX.net Vendor
    Join Date
    Mar 2004
    Location
    Los Angeles
    Posts
    494
    The pump may have prematurely stopped. I'd blame the pump equipment, rather than the gauge. My GMC will stop 2/3rd's of the way up, and it then takes about a dozen pulls on the handle to get it to full. The pump 'thinks' it's full when it's not. I've only had that problem with my WRX 2 maybe 3 times. If it keeps happening, do some research.
    Those fools, EVO vs. STi??? That's like comparing ....wait a minute...there's no comparison. The Suby's still working!!! The evo...well... I hope he got the extended warranty.

  6. #5
    Registered User ynotajb's Avatar
    Join Date
    Sep 2004
    Location
    mmmm,, tater salad
    Posts
    2,711
    Quote Originally Posted by ej20fan
    The pump may have prematurely stopped. I'd blame the pump equipment, rather than the gauge. My GMC will stop 2/3rd's of the way up, and it then takes about a dozen pulls on the handle to get it to full. The pump 'thinks' it's full when it's not. I've only had that problem with my WRX 2 maybe 3 times. If it keeps happening, do some research.
    very true... try a diff gas station and see what happens
    dude one time i tried to put the trailer bully into the coiler, and I got all messed up

  7. #6
    Registered User IHRTWRX's Avatar
    Join Date
    Mar 2005
    Location
    NOR CAL
    Posts
    944
    Quote Originally Posted by Entropy
    Ok i just bought the car two weeks ago so i am not terribly familiar with it. I just filled up the car after it was on E and it took 11.3 gallons...Dont all WRX's have a 15.9 gallon tank??? What gives? Could explain what i though was the horrible gas mileage!!!! I'm missing nearly 1/3 of the tank!!!
    After you filled up did the gauge read full? Or did it come up short? If it reads short then theres your answer. The pump premee shuts off. As ej20fan stated.

  8. #7
    Registered User Entropy's Avatar
    Join Date
    Nov 2004
    Location
    Northwest MT/ Calgary AB
    Posts
    23
    Nope, after i filled up the needle was just ABOVE the F on the gauge...I did try pumping the handle and got gas down the side of the car...pretty good indication the tank was full. Driving to Calgary today and will fill up when i get there. I'll see if the problem repeats itself!
    thanks for all your replys!

  9. #8
    Registered User IHRTWRX's Avatar
    Join Date
    Mar 2005
    Location
    NOR CAL
    Posts
    944
    Quote Originally Posted by Entropy
    Nope, after i filled up the needle was just ABOVE the F on the gauge...I did try pumping the handle and got gas down the side of the car...pretty good indication the tank was full. Driving to Calgary today and will fill up when i get there. I'll see if the problem repeats itself!
    thanks for all your replys!
    Yeah man thats weird. Let us know what happens.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •