Climate control knob problem?
Results 1 to 9 of 9

This is a discussion on Climate control knob problem? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I just turned my car to full defrost the other day (its getting colder here). I'm not sure if my ...

  1. #1
    Registered User thechickencow's Avatar
    Join Date
    Mar 2002
    Location
    West Allis, WI
    Posts
    3,099

    Climate control knob problem?

    I just turned my car to full defrost the other day (its getting colder here). I'm not sure if my car is normal, but there doesn't really seem to be a notch for the selector to go into at the last point. Anybody else noticed that?

    I've got an oil change coming up, and I was going to have them look at my window squeak, the defrost thing, and possibly the drivers seat (fraying at wallet).

    I also noticed that my front bumper is broken from its 'bracket' on both screws in the front wheel well on the front side. I'm assuming that these broke as a result of hitting cones autoxing, so i'm not going to worry about them for now.

    tcc

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Oct 2002
    Location
    Pittsburgh, PA
    Posts
    158
    Did you ever find out if the vent control knob was indeed a problem? I noticed the other day that my knob does the same thing that you described.
    '03 WRX wagon
    '97 Civic EX supercharged
    Beechjet 400A and Hawker 800 driver

  4. #3
    Registered User is2scooby's Avatar
    Join Date
    Jun 2002
    Location
    Honolulu, HI
    Posts
    4,234
    I think you guys might be in need of an adjustment - my climate control knobs have detents at all settings.
    Aloha, Richard...
    Retired Moderator
    TXS Stage 4 UTEC + TMIC + JoeP
    12.75 @ 105.67mph - 1.74 60'

  5. #4
    Registered User Wade-0's Avatar
    Join Date
    Dec 2002
    Location
    Southern Orygun
    Posts
    3,808
    Mine also does this, I noticed a couple days ago (but wasn't concerned). Every single setting has a distinct click except for the defogger (last position) and it just won't stay all the way right. I didn't worry too much about it though because I put my hands by all the vents and it's doing what it is supposed to, so big deal about the dial being off by 1/8".

    I think scoobies just have these quirks. My 2.5 wouldn't let me switch to recirc when the sunroof was open, it would just slide the lever back to fresh air on it's own. Now THAT was wierd (and kinda spooky)

  6. #5
    Moderator WilliamG's Avatar
    Join Date
    Nov 2002
    Location
    Seattle, WA
    Posts
    1,215
    I Support ClubWRX
    Yep my defogger does the same. Since the day I bought it.
    2010 SSM STI

  7. #6
    Registered User
    Join Date
    Jun 2002
    Location
    Central IL
    Posts
    718
    Mine also have a spongy feel when I select full defrost. It just never goes all the way down. I'm glad Im not the only one!
    Rubber Duckies Fair Well in the Rain

  8. #7
    Registered User
    Join Date
    Nov 2002
    Location
    Canada
    Posts
    20

    Re: Climate control knob problem?

    Originally posted by thechickencow
    I just turned my car to full defrost the other day (its getting colder here). I'm not sure if my car is normal, but there doesn't really seem to be a notch for the selector to go into at the last point. Anybody else noticed that?

    I've got an oil change coming up, and I was going to have them look at my window squeak, the defrost thing, and possibly the drivers seat (fraying at wallet).

    I also noticed that my front bumper is broken from its 'bracket' on both screws in the front wheel well on the front side. I'm assuming that these broke as a result of hitting cones autoxing, so i'm not going to worry about them for now.

    tcc
    WOW!!! you just described my car to a "T"!! my defrost dial will not even engage into the "full only" defrost mode.
    Also my seat is also frayed lower right side, and my window squeeks like you would not believe and the front lower air clip?!! yup mine too!! All those little plastic push in screws went for a $hit. I replaced them all with stainless 10-32 nuts and bolts, problem fixed!!...
    2 other things of notice anyone? when filling the gas tank, if I dont pay extra attention when filling the top portion, I'm wearing it!
    and lastly.....at about 160 clicks......she howls like nothing else!!
    it comes from the passenger side somewhere MIRRORS? maybe?
    first time it happened it scared me so bad I thought she was possessed!!! lol

  9. #8
    Registered User racerWRX's Avatar
    Join Date
    Jun 2002
    Location
    steeltown
    Posts
    1,315
    same thing w/ mine......hmmmm do i detect a recall .....naaaaa
    have you ever been 4 bagged ???

  10. #9
    Registered User Wade-0's Avatar
    Join Date
    Dec 2002
    Location
    Southern Orygun
    Posts
    3,808
    I had my dash apart while installing my Blitz DTT this weekend, and I took a look at the knob. There doesn't appear to be any adjustment mechanism for it, and it looks like it is engaging all the way, even though it doesn't click.

    I wouldn't worry too much about it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •