my clock broke
Results 1 to 6 of 6

This is a discussion on my clock broke within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; i have an 02 wrx wagon and about 4 nights ago i noticed the clock was off. i turned my ...

  1. #1
    Registered User c00lbeans's Avatar
    Join Date
    Apr 2005
    Location
    Portland, OR
    Posts
    2,222

    my clock broke

    i have an 02 wrx wagon and about 4 nights ago i noticed the clock was off. i turned my lights on and off a couple times and it came back on kind of dim then got to its normal brightness. next day it was off and still is. what should i check. fuse? loose wire? and where?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User c00lbeans's Avatar
    Join Date
    Apr 2005
    Location
    Portland, OR
    Posts
    2,222
    it would be rad if someone replied

  4. #3
    Registered User Death To Ricers's Avatar
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    1,930
    Well I dont know much about the electrical. My best guess would be a fuse or maybe the LCD just went out.
    2006 WRX
    Quote Originally Posted by RayfieldsWRX View Post
    You could vote to fix me a sammich.

  5. #4
    Registered User Hybrid-X's Avatar
    Join Date
    Feb 2002
    Posts
    925
    Is the whole clock dim or just one side? How about the other lights in the center console. Are those dim as well? I'm just asking because my car had those symptoms, but it was actually my battery that was dying. Anyways, I replaced my battery and everything was good. Not sure if this is the case for you, but you might want to check it out. Also, when you turn on the lights, do you notice any lights dimming inside the cabin?

  6. #5
    Registered User c00lbeans's Avatar
    Join Date
    Apr 2005
    Location
    Portland, OR
    Posts
    2,222
    battery is about 6 months old and is just fine. all the other lights work fine. the clock was completely off. it came back on today when i started my car this morning and is working fine but im sure it will go out agian

  7. #6
    WRX
    WRX is offline
    Registered User WRX's Avatar
    Join Date
    Nov 2002
    Location
    Montgomery, IL
    Posts
    2,671
    mine just did the same thing.
    13.12@101mph
    248whp 204lb/ft torque
    mods

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •