airbag light
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on airbag light within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; About a year ago I put a Blitz turbo timer on my WRX. Of course when I did that I ...

  1. #1
    Registered User
    Join Date
    Aug 2003
    Location
    Santa Maria, Ca
    Posts
    18

    airbag light

    About a year ago I put a Blitz turbo timer on my WRX. Of course when I did that I couldn't lock the doors while the car was running. On FastWRX's web site there were instructions on how to get the remote door locks to work again. The only problem was they didn't say which green wire with black stripe to cut. I cut the wrong one. I found better instructions on a diferent site and got it working, but the wire I cut must have something to do with the airbags cuz the light came on, on the dash. I spliced the wire back together but the light is still on. Is it possible cutting that wire caused perminent damage and now my airbags wont work or is there a way to reset it. Any info would be much apreciated. Thanks.

    Justin

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,933
    Quote Originally Posted by Oafboy
    About a year ago I put a Blitz turbo timer on my WRX. Of course when I did that I couldn't lock the doors while the car was running. On FastWRX's web site there were instructions on how to get the remote door locks to work again. The only problem was they didn't say which green wire with black stripe to cut. I cut the wrong one. I found better instructions on a diferent site and got it working, but the wire I cut must have something to do with the airbags cuz the light came on, on the dash. I spliced the wire back together but the light is still on. Is it possible cutting that wire caused perminent damage and now my airbags wont work or is there a way to reset it. Any info would be much apreciated. Thanks.

    Justin
    you didn't splice the wire back together correctly or good enough. There's a clip under the passenger seat that you have to have hooked up or hte airbag light will be on.

  4. #3
    Registered User
    Join Date
    Aug 2003
    Location
    Santa Maria, Ca
    Posts
    18
    I never touched anything under the passenger seat when i did the install. I'll try resplicing tomorrow. hopefully that works.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •