Help with this code please!?! P0430 Catalyst System Efficiency Below Threshold
Results 1 to 3 of 3

This is a discussion on Help with this code please!?! P0430 Catalyst System Efficiency Below Threshold within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; P0430 Catalyst System Efficiency Below Threshold (Bank 2) in case it didnt all fit. But i just bought a 2004 ...

  1. #1
    Registered User
    Join Date
    Jun 2004
    Location
    Enfield, CT
    Posts
    40

    Help with this code please!?! P0430 Catalyst System Efficiency Below Threshold

    P0430 Catalyst System Efficiency Below Threshold (Bank 2)

    in case it didnt all fit. But i just bought a 2004 sedan, and on my way on the highway today i popped a CEL, revving the engine to about 5k in 3rd gear trying to get on the highway from an onramp. Well i go to autozone to check it out and they tell me this...i go to the dealership and they say to bring it in and theyll look at it. They asked me if i got gas in the last week and i did, and they say tha tsometimes it will do a CEL if the gas cap isnt on tight enough...i doubt this is my problem...but i wanted to reset the CEL by pulling the ground...and tightening the cap but the dealer said dont touch anything...so theres no blame involved.

    what should i do? im pretty pissed already that i have a CEL, and something needs to be fixed, it totally blows my confidence in this specific car out the window...in my old ford escort zx2 i had never had a CEL, until about 86k, when the alternator went.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jun 2004
    Location
    Enfield, CT
    Posts
    40
    Ok heres what happened. APparently the flange that holds the O2 sensor broke, and the o2 sensor fell out of the cat, leaving a gaping hole, and popping the CEL. I brought it in, it was covered, came out a day later because i had to wait for the part...i had them change the oil and rotate tires...i also paid extra for some general checkup and fluid top off, and adjustments etc...and it seems they adjusted the wastegate arm, i notice less flutter and the car pulls much harder...i heard on NASIOC that subaru was making a kit to address this issue and would install it on waranteed vehicles...i didnt get to check under the hood yet, but i do notice a difference.

  4. #3
    Registered User
    Join Date
    Jun 2004
    Location
    Enfield, CT
    Posts
    40
    Ok heres what happened. APparently the flange that holds the O2 sensor broke, and the o2 sensor fell out of the cat, leaving a gaping hole, and popping the CEL. I brought it in, it was covered, came out a day later because i had to wait for the part...i had them change the oil and rotate tires...i also paid extra for some general checkup and fluid top off, and adjustments etc...and it seems they adjusted the wastegate arm, i notice less flutter and the car pulls much harder...i heard on NASIOC that subaru was making a kit to address this issue and would install it on waranteed vehicles...i didnt get to check under the hood yet, but i do notice a difference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •