Turbo Timer/ Lock problem
Results 1 to 9 of 9

This is a discussion on Turbo Timer/ Lock problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just installed a Blitz FATT X turbo timer last nite! Yesterday the timer ran fine, and i was able ...

  1. #1
    Registered User
    Join Date
    Apr 2004
    Posts
    26

    Turbo Timer/ Lock problem

    I just installed a Blitz FATT X turbo timer last nite!

    Yesterday the timer ran fine, and i was able to leave the car and lock the doors and wait till it the timer counted down to zero!

    But today i dunno what happened, after i turn off the ignition the timer still works fine but i can't seem to lock my doors till the timer counts down to zero!

    Which defeats the purpose to the turbo timer!
    *4EAT 2002 WRB WRX*

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User mourning_air's Avatar
    Join Date
    May 2003
    Location
    http://www.awdpirates.net
    Posts
    1,602
    Did you cut the wire under the dash? It's dark green and black.

    edit: follow these instructions Blitz Dual TT DC purple wire?
    Last edited by mourning_air; 06-14-2004 at 02:16 PM.
    <Ryan>
    '00 Silverthorn Metallic 2.5 RS
    '04 San Remo Red WRX Wagon

  4. #3
    Registered User
    Join Date
    Apr 2004
    Posts
    26
    i have the hardness!
    but it worked yesterday thats why i'm confused rite now
    *4EAT 2002 WRB WRX*

  5. #4
    Registered User mourning_air's Avatar
    Join Date
    May 2003
    Location
    http://www.awdpirates.net
    Posts
    1,602
    Originally posted by DBOi
    i have the hardness!
    I'm sure your excited about your new turbo timer but please try to contain yourself

    If you didn't cut the green and black wire on the security module then you will not be able to lock your doors while the car is running.
    <Ryan>
    '00 Silverthorn Metallic 2.5 RS
    '04 San Remo Red WRX Wagon

  6. #5
    Registered User
    Join Date
    Apr 2004
    Posts
    26
    ok i have a 2002~

    so i cut the green and black on the side of the fuse box rite?????

    i don't have a factory security so i don't need to cut the grey wire rite?
    *4EAT 2002 WRB WRX*

  7. #6
    Registered User mourning_air's Avatar
    Join Date
    May 2003
    Location
    http://www.awdpirates.net
    Posts
    1,602
    Yes, just cut the green and black wire attached to the security module just above the fuse box.
    <Ryan>
    '00 Silverthorn Metallic 2.5 RS
    '04 San Remo Red WRX Wagon

  8. #7
    Registered User BlkWRXWag's Avatar
    Join Date
    Jan 2003
    Location
    Trabuco Canyon, CA
    Posts
    2,236
    Originally posted by mourning_air
    I'm sure your excited about your new turbo timer but please try to contain yourself
    Funny stuff!

    And yes, listen to mourning_air - cut the green/black wire.

  9. #8
    Registered User
    Join Date
    Apr 2004
    Posts
    26
    OHHH It worked like a charm!

    THANKS ALOT mourning_air!
    *4EAT 2002 WRB WRX*

  10. #9
    Registered User mourning_air's Avatar
    Join Date
    May 2003
    Location
    http://www.awdpirates.net
    Posts
    1,602
    Glad that worked out for you.
    <Ryan>
    '00 Silverthorn Metallic 2.5 RS
    '04 San Remo Red WRX Wagon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •