Reverse lights on in any gear...help!!!
Results 1 to 13 of 13

This is a discussion on Reverse lights on in any gear...help!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I had my transmission replaced with a used one recently, and now it seems as if the reverse lights turn ...

  1. #1
    Registered User Bask Oner's Avatar
    Join Date
    Jun 2002
    Location
    Chicago, IL
    Posts
    2,587

    Reverse lights on in any gear...help!!!

    I had my transmission replaced with a used one recently, and now it seems as if the reverse lights turn on when the car is in gear. As a matter of fact, I got pulled over for it last night! Anyway, what could possibly be the problem, or at least, what makes the reverse lights do what they do?

    A quick response would be greatly appreciated, as I'm prone to tickets now, and my inspection is almost expired.

    Thanks!
    Matt
    WRX-less, now RSX-y!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ShotgunTC88's Avatar
    Join Date
    Nov 2002
    Location
    Ky
    Posts
    2,543
    Im pretty sure there is a switch on the Tranny that sends a signal to your back up lights.

    Peek under the car on the transmission, It should be a little round thingy with a wire comin off of it, Check to see if its plugged up.


    Best I can tell, I loaned my manual out


    Shotgun

  4. #3
    Registered User hybrid gti 2's Avatar
    Join Date
    Apr 2004
    Location
    lancaster
    Posts
    956
    ditto. the light is run off a switch so if you unplug it and it's gone you know why. check it soon as backup lights get hot and I have sceen them melt lights if gone unfixed.

  5. #4
    Registered User Bask Oner's Avatar
    Join Date
    Jun 2002
    Location
    Chicago, IL
    Posts
    2,587
    Bump! What could be wrong with the switch? The wires look connect to the front of the transmission.
    Matt
    WRX-less, now RSX-y!!!

  6. #5
    Registered User hybrid gti 2's Avatar
    Join Date
    Apr 2004
    Location
    lancaster
    Posts
    956
    switch is a bolt on to the trans likly. switch has crap in it and will not last forever idther when on the trans. so remove the wire problem goes away. now to fix thats another story. factory part and expect $$$. or mod your self a switch.

  7. #6
    Registered User Bask Oner's Avatar
    Join Date
    Jun 2002
    Location
    Chicago, IL
    Posts
    2,587
    Ah, a check engine light tells all!

    P1591 Neutral position switch circuit low input

    Now how do I fix that!?!?
    Matt
    WRX-less, now RSX-y!!!

  8. #7
    Registered User hybrid gti 2's Avatar
    Join Date
    Apr 2004
    Location
    lancaster
    Posts
    956
    darn that is for the cruz control. need to reset the computer. then buy a new switch. that stinks. I can't tell you how many switches I went throw with my golf.

  9. #8
    Registered User Bask Oner's Avatar
    Join Date
    Jun 2002
    Location
    Chicago, IL
    Posts
    2,587
    How do you know that it's for the cruise control? What would that have to do with my reverse lights?
    Matt
    WRX-less, now RSX-y!!!

  10. #9
    Registered User hybrid gti 2's Avatar
    Join Date
    Apr 2004
    Location
    lancaster
    Posts
    956
    if in cruz mode take it out of gear and see what happens. the engine will not rev. as for the lights it stinks but you will need a new switch. that is the only fix. for now might remove the bulbs. that and park way out of others way. did that for years with my golfs.

  11. #10
    Registered User TRBOBLU's Avatar
    Join Date
    Aug 2003
    Location
    Dearborn Heights, MI
    Posts
    43
    Don't know if you're still having the problem, but seeing as the problem just started when you had the transmission replaced, just go get another Trans Range Sensor.

    Another possibility is that the installer pinched some wiring when installing the trans.

    The best solution is to get yourself a wiring diagram and go from there.

  12. #11
    Registered User Bask Oner's Avatar
    Join Date
    Jun 2002
    Location
    Chicago, IL
    Posts
    2,587
    Does anyone know how I can disconnect the reverse lights in my '02 wagon? I think I've found a place to get a proper inspection (if you know what I mean).
    Matt
    WRX-less, now RSX-y!!!

  13. #12
    Registered User TRBOBLU's Avatar
    Join Date
    Aug 2003
    Location
    Dearborn Heights, MI
    Posts
    43
    Very easy if you just want to disconnect the reverse lamps. Ummmm, this is for off-road use only....

    You'll need a screwdriver to pop the center of the plastic retainers in the trunk, then pull back the trunk liner to access the taillamps.

    All you need to do is rotate the socket for the bulb 1/4-turn counterclockwise, remove the bulb, then put the socket back in the taillamp (to prevent moisture from entering the lens).

    Easy enough. It will take you all of 10 minutes, tops.

  14. #13
    Registered User TRBOBLU's Avatar
    Join Date
    Aug 2003
    Location
    Dearborn Heights, MI
    Posts
    43
    Ooooops, just saw the "wagon" part, but the process should be similar.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •