HELP!!! Engine revving by itself!!! - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

This is a discussion on HELP!!! Engine revving by itself!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have an HKS BOV. No leaks and everything seems fine. It idles at 500 and stays there, it doesn't ...

  1. #16
    Registered User Rippa's Avatar
    Join Date
    May 2003
    Posts
    92
    I have an HKS BOV. No leaks and everything seems fine. It idles at 500 and stays there, it doesn't fluctuate. My guess is that the cables were on too tight from factory because I've never messed around with them before. It wasn't the BOV cause my bro has the same car, same everything, and I traded BOV's to see if that was the problem, It wasn't. I even went out of my way to put the stock BOV on but still revved out of control, so it didn't make a difference. Finally, yes I took the car for the recall but that didn't seem to fix the problem because it started up afterwards. Well all is well with my car for now. Thanks for all the input.

    Will
    Last edited by Rippa; 05-19-2004 at 12:39 PM.
    310whp / 309trq @ 19psi
    Now with 6 Flavors of JDM Goodness!!
    MODS

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User driverj's Avatar
    Join Date
    Jan 2003
    Location
    916
    Posts
    1,184
    Will,

    Definitely check the cables especially the cruise control which was the culprit for the other person I spoke about earlier. Just loosen it up a bit and see if it helps.

    Good luck.

  4. #18
    Registered User AWDrifter21's Avatar
    Join Date
    Sep 2003
    Location
    NJ
    Posts
    241
    Originally posted by Mad WRX
    750
    500
    ------------
    AWDrifter
    ------------

  5. #19
    Registered User
    Join Date
    Sep 2001
    Location
    Edmonds, Washington
    Posts
    542
    Originally posted by AWDrifter21
    500
    No, you're reading your gauge wrong, read the increments down from 1000 and you'll find the car idles at ~750rpm. Lots of people make the mistake.

    edit:

    Taken straight from page SPC-2 of the factory service manual:

    Idle speed at park/neutral : 2.0L Turbo (A/C off): 750rpm
    Last edited by supermarkus; 05-19-2004 at 11:47 PM.
    http://homepage.mac.com/supermarkus/PhotoAlbum1.html

    Mullet haiku:
    Daughter's BMX
    Takes me to welfare office
    Trans Am is on blocks

  6. #20
    Registered User AWDrifter21's Avatar
    Join Date
    Sep 2003
    Location
    NJ
    Posts
    241
    Hhhmm.... guess you are right.... thanks for proving me wrong, hehe
    Its just that A LOT of people have been saying 500, and I see 500.
    but whatever, 500-750, not too big of a difference
    ------------
    AWDrifter
    ------------

  7. #21
    Registered User
    Join Date
    May 2004
    Location
    Nevada
    Posts
    6

    Stuck Throttle

    Dear Will,

    Take your car to the Subaru dealer and get the service related to the WWQ-01 safety recall. Then read my thread on the topic. It caused 13 thousand dollars worth of damage to my car and came incredibly close to killing my father. But for the Grace of God...!!!
    NotDeadYet

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •