Idle @2k and running lights always on...
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Idle @2k and running lights always on... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I purchased my subaru from a fellow board member and its been nothing but good to me untill today. i ...

  1. #1
    Registered User
    Join Date
    Jan 2004
    Location
    MI
    Posts
    414

    Unhappy Idle @2k and running lights always on...

    I purchased my subaru from a fellow board member and its been nothing but good to me untill today.
    i washed my subaru and returned home to take pictures, upon starting my car up i realized that something wasnt right, my car is idleing at 1.75-2k. i drove it up to a nearby school and started to take pictures when i realized that the running lights are always on now too (even if keys arnt in ignition and lights are off).
    im fairly sure this is some kind of electrical problem, so i probably have to take it to the dealership (onlk 22k on it) to have it fixed.
    my next concern is that it has some mods, a cone intake, blitz blowoff valve, helix downpipe and exhaust. i hear that i have a very reasonable subaru dealer nearby (Hoges subaru in Royal Oak, Michigan) but i dont think they will take kindly to the moded o2 sensor (came with helix downpipe). what percautions can be taken? has anyone ever heard of a problem like this?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Vendeta2K's Avatar
    Join Date
    Aug 2003
    Location
    Northern California
    Posts
    1,236
    Not sure about the high idleing......but check the top of your steering column......there is a switch up there for the parking lights, not the hazards....you might have bumped it lately? That would be my guess at the parking lights.
    vendeta2k
    Accessport + COBB SF Intake = BEST MOD EVAR!!!!!

  4. #3
    Registered User
    Join Date
    Jan 2004
    Location
    MI
    Posts
    414
    Originally posted by Vendeta2K
    Not sure about the high idleing......but check the top of your steering column......there is a switch up there for the parking lights, not the hazards....you might have bumped it lately? That would be my guess at the parking lights.
    thanks! i guess im still geting use to the car. what would the functional purpose of this switch? i just dont see how it would come in handy at any point in time...
    The idle problem went away after i disconected the neg battery cable and it hasnt returned. this problem still conserns me though. i wonder if it is worth taking into the dealer still. im worried about some sort of blacklisting because of the mods. i know the previous owner had the body kit painted at Hoges subaru, but i dont think that really would affect anything related to the warranty.

  5. #4
    Registered User JTREX's Avatar
    Join Date
    Mar 2002
    Posts
    567
    Originally posted by BigClunke
    thanks! i guess im still geting use to the car. what would the functional purpose of this switch? i just dont see how it would come in handy at any point in time...
    Gives you the ability to use the parking lights w/o the car running or the key in the "on" position. Seem to remember this being a requirment in some Euro. countries
    Drag racing? I like my racing to last longer than the average orgasm...

  6. #5
    Registered User Vendeta2K's Avatar
    Join Date
    Aug 2003
    Location
    Northern California
    Posts
    1,236
    Glad that helped.......as far as the idling goes.......maybe when ya washed it, something in the motor got wet...really wet? I've noticed that after I give mine a good bath at the power wash, it sometimes tends to idle a little high......but goes away after a few miles of driving.
    vendeta2k
    Accessport + COBB SF Intake = BEST MOD EVAR!!!!!

  7. #6
    Registered User
    Join Date
    Jan 2004
    Location
    MI
    Posts
    414
    hasnt returned yet i'm hopeing it was because i got too much water in the scoop while washing it.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •