CEL - what's going on?
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on CEL - what's going on? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok i tried this post at another forum and no answers, so i gonna try here. I just picked up ...

  1. #1
    Registered User thuynh2's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    71

    CEL - what's going on?

    ok i tried this post at another forum and no answers, so i gonna try here.

    I just picked up my wrx yesterdat (june 14), at marino's. on the way home (about 4hrs away) about 1 hour after leaving the dealer the CEL comes on. So, what happened? should i be worried? what should i do?

    I kept revs under 4k and stopped at every rest-stop on the way home and allowed her to cool before shutdown.

    any input would be helpful,
    thanks
    --thuynh2

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderating YOU
    before you had your Subaru!
    Verdugo's Avatar
    Join Date
    Jan 2002
    Location
    Sea-Town, WA
    Posts
    13,313
    I Support ClubWRX
    Did you make sure the gas cap was secured all the way? Maybe the dealer filled it with gas but didn't screw it in enough...that's enough to cause a CEL.
    Armin - ClubWRX Admin/Moderator since 2002
    Vice President and Editorial Manager, NWMotiv.com
    Photography Portfolios: ArminAusejo.com | ArminWeddings.com
    President, Project One Car Club
    02 WRX "EVA-00" | 15 Audi S3 "Ella" | 2010 A4 (traded in) | 02 M3 "M-Thrizzle" (traded in) | 08 STI "Blaze" (sold)
    djrez4 is a genius | ScoobyDMC #010

  4. #3
    Registered User thuynh2's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    71
    yeah i made sure that gas cap was on tight. Infact when i went to pick it up the salesman 'introduced' me to the car and all of the options and how to work everything... even the gas cap and he said 'make sure it is on tight or else it might trigger a check engine light'.

    anways i have about 460kms on the car now, it was at 23km when i got it (400 km from dealer to get home) and the check engine light is still on. I'm driving her easy, gotta break in anyways. I'm thinking of taking her in on monday to a dealer that is closer to home to see whats the matter.

    so, does anyone know what might be wrong?

    thanks guys,
    thuynh2

  5. #4
    Registered User
    Join Date
    Jun 2002
    Location
    Morris Plains NJ
    Posts
    4
    did you ever find out what produced the CEL?

  6. #5
    Registered User thuynh2's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    71
    nope, it went out on its own. weird...


    thuynh2

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •