New control arm goes CLUNK ... WTF??
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on New control arm goes CLUNK ... WTF?? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; *takes a deep breath* Long story short... I had funny alignment problems. The mechanics at the dealership said the caster ...

  1. #1
    Registered User element533's Avatar
    Join Date
    Dec 2002
    Location
    Sacramento, CA
    Posts
    56

    Angry New control arm goes CLUNK ... WTF??

    *takes a deep breath*

    Long story short...

    I had funny alignment problems. The mechanics at the dealership said the caster was off. So they put it on the frame rack and discovered that the control arm was bent. They replaced it.

    Now I hear a "clunk" every once in a while when I'm driving. It's always at low speeds, usually when I'm starting from a stop, sometimes when I go over a bump, sometimes not. The "clunk" sound is DEFINITELY new and is DEFINITELY coming from the side where they replaced the control arm.

    Does anybody have any idea what this could be? I'd like to have an idea before I call the dealership, just so I can know what I'm talking about...

    Thanks a lot...
    Speedometer? Is that the thing next to the tach?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User KanosWRX's Avatar
    Join Date
    Dec 2001
    Location
    Northern VA
    Posts
    3,975
    My guess is they forgot to tighten a bolt or something else is loose down there.


    My Mods


    "The most important mod is the one behind the steering wheel" - Koyokid RIP

  4. #3
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,592
    I Support ClubWRX
    Check to see if any of the bolts are loose, and also check the play on the ball joint.

  5. #4
    Registered User element533's Avatar
    Join Date
    Dec 2002
    Location
    Sacramento, CA
    Posts
    56
    thanks for the replies... it turns out they forgot to tighten the bracket to the frame. all better now!
    Speedometer? Is that the thing next to the tach?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •