dumb waxing question...
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on dumb waxing question... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i just got a brand new wrx...and i was trying to wax the car yesterday...and it seems like the wax ...

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    23

    dumb waxing question...

    i just got a brand new wrx...and i was trying to wax the car yesterday...and it seems like the wax wont go on, on some parts of the car...eg. top of front bumper, left and right of hood scoop, no matter how many times i wax it...it still feels not waxed...can someone tell me y?

    thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Irvine, CA
    Posts
    5
    My rex is pretty new too and I noticed the same thing when waxing mine for the first time. I don't know if you saw at your dealership but when the cars first come in they have plastic adhesive over parts of the paint to prevent damage while shipping.

    It takes several good washings to really get the residue off, which is why your wax isn't taking so well. Also, it depends on what kind of wax you are using. I would recommend a real carnuba wax and not a silicone-based "wax."

    I wholeheartedly recommend www.malms.com (I don't work for them, just someone who has used their stuff for the past 10 years and has been extremely pleased with the results on new, old, light, and dark paints)

    Stephen

  4. #3
    Registered User GTIWRX's Avatar
    Join Date
    Mar 2002
    Location
    Conshohocken,PA
    Posts
    3,273
    yeah i agree, when i got my car i insisted the dealer buffed it before i picked up it, she looked great, the wax seemed to stick fine though. Take it to a shop and get a professional buffing, it will look great only will cost like 50 bucks and will probobly get that crap off! aw man now im thinkin about that feelin i got when i drove my car off the lot...and then stalled it on the main road runnin through albany, haha good times!

  5. #4
    Registered User
    Join Date
    Mar 2003
    Location
    Socal
    Posts
    25
    Waxed mine 2 weeks after i got it, no prob......I only use Miguires Gold Class, Xlnt product, easy on, easy off.....Paint is more than cured, maybe you need to wash it better, what do you use for suds???
    " Hey its only money, we'll make more "

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •