Power Steering problems
Results 1 to 11 of 11

This is a discussion on Power Steering problems within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I need help guys...before I take my car to the dealer I was wondering if anyone else was having similar ...

  1. #1
    Registered User WRXRATED7's Avatar
    Join Date
    Oct 2002
    Location
    Omaha, Nebraska
    Posts
    193

    Power Steering problems

    I need help guys...before I take my car to the dealer I was wondering if anyone else was having similar probs.

    '03 WRX sedan, 4k miles.

    It snowed here last week and I did some parking lot drifting/cookies the night it snowed. Ever since then it seems like my car doesn't want to turn well. I didn't hit any curbs. I checked the lugnuts and p/s fluid levels and both are fine.

    It seems that either at a dead stop or at low speeds the power steering doesn't want to work.

    Thanks,
    Todd
    '05 Obsidian Black STi (my dream has come true)
    '93 SE-R (JDM SR20DE waiting...)
    '69 Camaro SS (project car)

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User djrez4's Avatar
    Join Date
    Jul 2002
    Location
    Colorado
    Posts
    3,858
    If you had your steering wheel turned all the way to lock for more than about 15 seconds, you might have blown your P/S pump. Take it in to the dealer and have them check it out.
    Deliberating enclaves of like-minded people are often a breeding ground for extreme movements - Cass Sunstein

  4. #3
    Registered User is2scooby's Avatar
    Join Date
    Jun 2002
    Location
    Honolulu, HI
    Posts
    4,234
    Agreed. Full lock for more than a little bit isn't kind to our power steering systems. Get it checked out at the dealer (if you're mod-free! )
    Aloha, Richard...
    Retired Moderator
    TXS Stage 4 UTEC + TMIC + JoeP
    12.75 @ 105.67mph - 1.74 60'

  5. #4
    Registered User WRXRATED7's Avatar
    Join Date
    Oct 2002
    Location
    Omaha, Nebraska
    Posts
    193

    Thumbs down

    Yeah guys...I was doing cookies in the snow. It was fun at the time, but I had no idea I would hurt my WRX.
    '05 Obsidian Black STi (my dream has come true)
    '93 SE-R (JDM SR20DE waiting...)
    '69 Camaro SS (project car)

  6. #5
    Registered User djrez4's Avatar
    Join Date
    Jul 2002
    Location
    Colorado
    Posts
    3,858
    Cookies (donuts?) are fine. They'll just head up your diffs nicely. Just don't lock the steering.
    Deliberating enclaves of like-minded people are often a breeding ground for extreme movements - Cass Sunstein

  7. #6
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    check your wheel wells and inside the rims for clumps of frozen ice and snow.

    dR

  8. #7
    Registered User WRXRATED7's Avatar
    Join Date
    Oct 2002
    Location
    Omaha, Nebraska
    Posts
    193
    Originally posted by dark_rex
    check your wheel wells and inside the rims for clumps of frozen ice and snow.

    dR
    Did that already and that wasn't it.

    Took my WRX to the dealer today and they just called me back. Looks like the power steering pump is going out. GOOD NEWS is that they're covering it by my warranty.
    '05 Obsidian Black STi (my dream has come true)
    '93 SE-R (JDM SR20DE waiting...)
    '69 Camaro SS (project car)

  9. #8
    Registered User WRXRATED7's Avatar
    Join Date
    Oct 2002
    Location
    Omaha, Nebraska
    Posts
    193

    Thumbs up

    My WRX is all fixed just in time for the snow today.
    '05 Obsidian Black STi (my dream has come true)
    '93 SE-R (JDM SR20DE waiting...)
    '69 Camaro SS (project car)

  10. #9
    Registered User is2scooby's Avatar
    Join Date
    Jun 2002
    Location
    Honolulu, HI
    Posts
    4,234
    Took them that long to get the pump replaced?!?! 1/22-2/3?
    Aloha, Richard...
    Retired Moderator
    TXS Stage 4 UTEC + TMIC + JoeP
    12.75 @ 105.67mph - 1.74 60'

  11. #10
    Registered User WRXRATED7's Avatar
    Join Date
    Oct 2002
    Location
    Omaha, Nebraska
    Posts
    193
    I drove my car in some of the meantime. It wasn't so bad that I couldn't steer at all...all the time.

    I was waiting for the part, then I called them back and that took forever...then I had to wait until they could get my car back into the shop. I got a nice new Hyundai Santa Fe as loaner. haha.
    '05 Obsidian Black STi (my dream has come true)
    '93 SE-R (JDM SR20DE waiting...)
    '69 Camaro SS (project car)

  12. #11
    Registered User is2scooby's Avatar
    Join Date
    Jun 2002
    Location
    Honolulu, HI
    Posts
    4,234
    Aloha, Richard...
    Retired Moderator
    TXS Stage 4 UTEC + TMIC + JoeP
    12.75 @ 105.67mph - 1.74 60'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •