please tell me I didn't fry my ecu
Results 1 to 2 of 2

This is a discussion on please tell me I didn't fry my ecu within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So my battery was dead at work this afternoon. My buddy pulls his car up to help me jump it ...

  1. #1
    Registered User cdogg240's Avatar
    Join Date
    Jul 2006
    Location
    Southport, NC
    Posts
    330

    please tell me I didn't fry my ecu

    So my battery was dead at work this afternoon. My buddy pulls his car up to help me jump it off. I hook it up fine to my car but like an idiot, I didn't check him hooking the jumper cables up to his. I hop in my car and as soon as I put the key in the ignition the horn starts blaring. I immediatley pull the cables off my car and fix the problem.

    When I hooked it up correctly the car would not do a thing. The only thing that works are the door locks and the chime when the key is in the ignition. I was in a rush so I took a different vehicle home and left mine at work.

    Am I screwed when I get to work tomorrow? Or by chance have a just blown a fuse. I really don't want to replace my ecu/utec.
    18g + ppg =

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User cdogg240's Avatar
    Join Date
    Jul 2006
    Location
    Southport, NC
    Posts
    330
    whew. Blew the main fuse 80A and the fuse on my amp. A quick trip to advance and 4 dollars later I am back in business.
    18g + ppg =

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •