HELP!! P0420 o2 code why?? new cats....wtf
+ Reply to Thread
Results 1 to 11 of 11

This is a discussion on HELP!! P0420 o2 code why?? new cats....wtf within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So I've had the Perrin divorced downpipe with cats on for around four months now. All was well OBD readiness ...

  1. #1
    Registered User Destros's Avatar
    Join Date
    Apr 2007
    Location
    Springfield, VA.
    Posts
    158

    Exclamation HELP!! P0420 o2 code why?? new cats....wtf

    So I've had the Perrin divorced downpipe with cats on for around four months now. All was well OBD readiness was set on all monitors, and no CEL. I just recently installed the Perrin uppipe with EGT sensor delete, and even installed the 2.2k ohm resistor in place of the sensor to fool the brain... Last night I threw a P0420 catalyst inefficiency code. I know it's not the cats because I HAVE cats and had no CEL for four months. Is it coincidentally a bad downstream sensor, or could something else be the fault?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User SubyPsycho's Avatar
    Join Date
    Apr 2005
    Location
    PA
    Posts
    546
    Just because you have cats, doesn't necessarily mean that the exhaust coming out of them is what the 02 sensor expects to see. High-flow cats typically let more of the bad stuff through. When the o2 sensor reads higher o2 levels, it means that the cats are binding o2 molecules to the carbon molecules in the exhaust as effectively as they should. The main job of the cats is to bond oxygen to carbon particles coming out of the engine, thus making CO2 instead of black soot. If there is more o2 in the exhaust gas, it means not enough o2 is being bonded to carbon, so the o2 sensor tells your computer that something isn't working right.

    If I were you, I'd stop messing around with resistors and get some EM.

  4. #3
    Registered User kiger0183's Avatar
    Join Date
    Oct 2005
    Location
    SLC, Ut
    Posts
    617
    +2 for EM
    Stage II and loving it!

  5. #4
    Registered User Destros's Avatar
    Join Date
    Apr 2007
    Location
    Springfield, VA.
    Posts
    158
    do you think I'm throwing codes now because of the uppipe?
    -created in the ominous shadow of The Great Vassar-
    Blobeye Syndicate #Eleventy-Seven

  6. #5
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    Quote Originally Posted by Destros View Post
    do you think I'm throwing codes now because of the uppipe?
    you ARE most CERTAINLY throwing that code due to the up pipe...look into some engine management...
    New England F4

    feel free to pm me with any questions..

  7. #6
    Registered User Destros's Avatar
    Join Date
    Apr 2007
    Location
    Springfield, VA.
    Posts
    158
    I'm saving up for Cobb tuning AP plug and play, but not there yet. Is there a way to have it run right without EM yet? ..... the car is slow now, and this is not acceptable....
    -created in the ominous shadow of The Great Vassar-
    Blobeye Syndicate #Eleventy-Seven

  8. #7
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    Quote Originally Posted by Destros View Post
    I'm saving up for Cobb tuning AP plug and play, but not there yet. Is there a way to have it run right without EM yet? ..... the car is slow now, and this is not acceptable....
    go back to stock....save faster?
    New England F4

    feel free to pm me with any questions..

  9. #8
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    Get rid of that resistor business. To get rid of the CEL I'd use A. EM or B. the mech. cel fix. This is pretty much just a few spark plug antifoulers spacing your 02 sensor.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  10. #9
    Registered User Destros's Avatar
    Join Date
    Apr 2007
    Location
    Springfield, VA.
    Posts
    158
    You have more info about the antifouler setup? The mechanical CEL fix.
    -created in the ominous shadow of The Great Vassar-
    Blobeye Syndicate #Eleventy-Seven

  11. #10
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    try a search on Nazioc. That's where I found the instructions and whatnot I believe. "Mechanical CEL fix" "mech CEL fix" "antifoulers"

    That kinda thing.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  12. #11
    Registered User Destros's Avatar
    Join Date
    Apr 2007
    Location
    Springfield, VA.
    Posts
    158
    thanks I shall pursue this further...
    -created in the ominous shadow of The Great Vassar-
    Blobeye Syndicate #Eleventy-Seven

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •