Help!!! CEL light and Cruise Control light on????
Results 1 to 11 of 11

This is a discussion on Help!!! CEL light and Cruise Control light on???? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey everyone, started my car today and the CEL light came on and was steady and my Cruise Control light ...

  1. #1
    Registered User PLSubaru98's Avatar
    Join Date
    May 2007
    Location
    Edison, NJ
    Posts
    63

    Help!!! CEL light and Cruise Control light on????

    Hey everyone, started my car today and the CEL light came on and was steady and my Cruise Control light was blinking. I have no mods done to my car. It is an 07 WRX with 3,000 miles on it. Has anyone ever had a problem like this one or heard about one like it??? Thanks ahead for any feed back
    Hawk-Eye Alliance #98
    SEXY 2007 UG WRX LTD
    Mods:
    SPT Intake

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User scooby2.0t's Avatar
    Join Date
    Apr 2006
    Location
    salisbury,MD
    Posts
    131
    get the code pulled.
    2002 WRB WRX- XPT Stage 2 Awaiting 25% more displacement!!

    got grip?

  4. #3
    Registered User ntg06's Avatar
    Join Date
    Nov 2006
    Location
    MSG
    Posts
    160
    it happend to me a while back but it went away in about a day.

  5. #4
    "Supreme Subaphile Extraordinairre" ninefourteener's Avatar
    Join Date
    Mar 2006
    Location
    SLC area
    Posts
    2,190
    Are you using an EM??

    Cobb lets you reset the ECU, problem fixed.

    If not, disconnect both battery terminals for a few minutes, then reconnect.. a lot of times that will fix it.

    If it comes back on, you have a "real" problem.
    2006 Subaru WRX-Thread: http://www.clubwrx.net/forums/engine-modifications/165158-ninfourteeners-progress-thread-pics.html
    1978 Subaru BRAT-Thread: http://www.clubwrx.net/forums/engine...ss-thread.html
    2007 Subaru B9Tribeca Ltd (PSM)........1994 Subaru SVX LSi(SOLD)
    WRX 12 sec drag (vs. late model Camaro SS):http://www.youtube.com/watch?v=lw0vWdD2cjU
    WRX track racing (catching a stg.2 WRX): http://www.youtube.com/watch?v=mELeSD1Mi08
    Co-Founder/retired Admin-www.slcsubaru.com

  6. #5
    Registered User PLSubaru98's Avatar
    Join Date
    May 2007
    Location
    Edison, NJ
    Posts
    63
    No...not using an EM but i am brining the car in to the dealership tomrrow...ill ask them for the code and update you guys...thanks again
    Hawk-Eye Alliance #98
    SEXY 2007 UG WRX LTD
    Mods:
    SPT Intake

  7. #6
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,417
    I Support ClubWRX
    Quote Originally Posted by PLSubaru98 View Post
    No...not using an EM but i am brining the car in to the dealership tomrrow...ill ask them for the code and update you guys...thanks again
    You install a boost gauge? If you did and you have a wrx I know the hose that might have fallen off and if the dealer finds it they charge you.
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  8. #7
    Registered User PLSubaru98's Avatar
    Join Date
    May 2007
    Location
    Edison, NJ
    Posts
    63
    Quote Originally Posted by 06wrx4me View Post
    You install a boost gauge? If you did and you have a wrx I know the hose that might have fallen off and if the dealer finds it they charge you.
    No it came with the factory boot gauge
    Hawk-Eye Alliance #98
    SEXY 2007 UG WRX LTD
    Mods:
    SPT Intake

  9. #8
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,417
    I Support ClubWRX
    Quote Originally Posted by PLSubaru98 View Post
    No it came with the factory boot gauge
    I bet the boost line fell off the stupid blue coupler. 2 min fix, but if the car came with it take it in make them deal with it.
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  10. #9
    Registered User PLSubaru98's Avatar
    Join Date
    May 2007
    Location
    Edison, NJ
    Posts
    63
    hey everyone...i got an update at 5:00 from the dealer while i was at work. They hooked the wrx to a computer and two codes came out (PO301) and (PO303) these are misfires in cylinder 1 and 3. i was wondering if anyone could explain to me what causes this to a car with no mods and only 3k miles on it. Also if anyone has any other experiences with this that could tell what wound up happening. Also is this or can this be a serious problem. Thanks ahead.

    I Miss my Subie
    Hawk-Eye Alliance #98
    SEXY 2007 UG WRX LTD
    Mods:
    SPT Intake

  11. #10
    Registered User SubyPsycho's Avatar
    Join Date
    Apr 2005
    Location
    PA
    Posts
    546
    A lot of things can cause misfires. Bad gas is usually the cause. If it's octane is too low it will cause detonation and pinging, which the computer could read as misfires. Bad gas could also cause buildups on the plugs, but with only 3k, I doubt it would have built up enough to cause misfires that bad.

    It also could be bad wires from the ignition control unit to the coilpacks, or the unit itself could be bad...

    I guess what I'm saying is that something is definitely bad, but without doing some testing and trial-and-error troubleshooting, it's hard to know what.

  12. #11
    Registered User PLSubaru98's Avatar
    Join Date
    May 2007
    Location
    Edison, NJ
    Posts
    63
    Update from the dealer...i called the guy this morning and he told me that the computer is reading a misfire code for cylinders 1 and 3 but when checking the sparkplugs, coils, and what not that the engine really isnt misfiring at all. He is calling SOA to see if they have any bulletins on this and is gonna let me know. So im guessing that there is something wrong with the ecu maybe???
    Hawk-Eye Alliance #98
    SEXY 2007 UG WRX LTD
    Mods:
    SPT Intake

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •