Not working turbo
Results 1 to 8 of 8

This is a discussion on Not working turbo within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have an 02 WRX and I bought it new... i haven't done enything under the hood to it but ...

  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    Not working turbo

    I have an 02 WRX and I bought it new... i haven't done enything under the hood to it but suddenly the turbo isn't working anymore....any ideas.... leaks??? broken pipes??? I would like to do the fix myself...any help will be greatly appreciated.
    Thanks
    seros :confuesd:

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Quote Originally Posted by seros View Post
    I have an 02 WRX and I bought it new... i haven't done enything under the hood to it but suddenly the turbo isn't working anymore....any ideas.... leaks??? broken pipes??? I would like to do the fix myself...any help will be greatly appreciated.
    Thanks
    seros :confuesd:
    do u have a boost gauge? are you showing no boost or do you feel the car not building boost?
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  4. #3
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,515
    I Support ClubWRX
    Quote Originally Posted by D0WNxSH1FT View Post
    do u have a boost gauge? are you showing no boost or do you feel the car not building boost?
    +1 more info please! If you KNOW the turbo is gone for sure, check out the for sale section. Or you can PM EFMD3 I know he is selling a turbo, I am sure there are others for sale as well. Good luck, thanks for coming around.!


    Lead Wrench @ WTF Tuning, LLC

  5. #4
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    Thumbs up not working turbo....

    Quote Originally Posted by LPPTundWRX View Post
    +1 more info please! If you KNOW the turbo is gone for sure, check out the for sale section. Or you can PM EFMD3 I know he is selling a turbo, I am sure there are others for sale as well. Good luck, thanks for coming around.!
    Thank you guys!
    I do not know for sure if the turbo is gone....I checked last night for leaks and I found one on the inlet pipe....which I do not think will impact that much in creating boost....

    responding to the boost question...I do not have a boost gauge..unfortunately....but I can feel that there is no boost at all...even a hybrid will overtake easily.

    I will check in the 'for sale' section anyways....

    I do want to take the turbo out but I do want to have the spare ready just in case....otherwise I have no car!!!!
    thanks

  6. #5
    Registered User dcpatters's Avatar
    Join Date
    Sep 2004
    Location
    Irvine, CA
    Posts
    1,174
    I would confirm the turbo is kapput before investing in a new one. If there is 0 boost, sounds like the wastegate is open. Has the heatshield ever been taken off the turbo? Is the wastegate arm still attached?
    2008 Evo X GSR. Custom tuned, Works panel filter, Intercooler pipe upgrade, TBE.

  7. #6
    Registered User powder's Avatar
    Join Date
    Aug 2006
    Location
    WA State
    Posts
    3,595
    Quote Originally Posted by seros View Post
    Thank you guys!
    I do not know for sure if the turbo is gone....I checked last night for leaks and I found one on the inlet pipe....which I do not think will impact that much in creating boost....

    responding to the boost question...I do not have a boost gauge..unfortunately....but I can feel that there is no boost at all...even a hybrid will overtake easily.

    I will check in the 'for sale' section anyways....

    I do want to take the turbo out but I do want to have the spare ready just in case....otherwise I have no car!!!!
    thanks
    Take the downpipe off and try to spin the turbine. Should be really easy. If it's not freespinning then you're seized.
    Blobeye Syndicate #2004
    Military Militia #30-06

    2004 WRX - JBP:Stage 2:13.93 @ 96

    Wingless alas. Too bad it took a 50 ton truck to make it happen.

  8. #7
    Registered User
    Join Date
    Oct 2005
    Location
    Vernal, UT
    Posts
    13
    check the downpipe to see if any of the metal in it separated and tore up your turbo. thats what happened to mine.

  9. #8
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    Cool

    Quote Originally Posted by powder View Post
    Take the downpipe off and try to spin the turbine. Should be really easy. If it's not freespinning then you're seized.
    I will take the dwon pipe off next weekend and try to spin the turbine...great idea.....the turbo and other parts look pretty good and never been touched....

    I will get back to you guys after I do so...thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •