engine re-install help!
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on engine re-install help! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Well, I've re-installed a 2.5L engine in my 02 wrx after having to replace the rod bearings. I have just ...

  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    4

    engine re-install help!

    Well, I've re-installed a 2.5L engine in my 02 wrx after having to replace the rod bearings. I have just about everything lined and attached, except I've encountered a few pieces that I cannot find any refference to in the service manual and am now stuck. If anyone could please provide information or confirmation about the following pictures, I'd greatly appreciate it.

    Pic #1 - I'm relatively certain that this black connector is part of the PCV control system. The open end that my hand is touching should route into the air intake duct and the hose by my thumb should route under the throttle body. If someone could confirm or deny this please.


    Pic #2 - I cannot find any reference to this outlet [identified by the tool handle pointing at it] anywhere on any of the diagrams in the service manual. If someone could tell me what system this is appart of or where it routes to, I'd greatly appreciate it.


    Pic #3 - this is a line coming from right under the throttle body that I'm assuming is pressurized. Again, I can't find any reference in the service manual to indicate where this goes.


    Pic #4 - a hose that fell off during the removal that I have absolutely no idea where it routes back to now.


    Otherwise, I have everything else routed and accounted for. So, any and all help is greatly appreciated. (Should have taken pics before hand, but that's neither here nor there)
    Last edited by lostinthought; 07-06-2007 at 02:10 PM. Reason: attempt to fix possible photo problem.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    Quote Originally Posted by lostinthought View Post
    Well, I've re-installed a 2.5L engine in my 02 wrx after having to replace the rod bearings. I have just about everything lined and attached, except I've encountered a few pieces that I cannot find any refference to in the service manual and am now stuck. If anyone could please provide information or confirmation about the following pictures, I'd greatly appreciate it.

    Pic #1 - I'm relatively certain that this black connector is part of the PCV control system. The open end that my hand is touching should route into the air intake duct and the hose by my thumb should route under the throttle body. If someone could confirm or deny this please.


    Pic #2 - I cannot find any reference to this outlet [identified by the tool handle pointing at it] anywhere on any of the diagrams in the service manual. If someone could tell me what system this is appart of or where it routes to, I'd greatly appreciate it.

    Pic #3 - this is a line coming from right under the throttle body that I'm assuming is pressurized. Again, I can't find any reference in the service manual to indicate where this goes.


    Pic #4 - a hose that fell off during the removal that I have absolutely no idea where it routes back to now.


    Otherwise, I have everything else routed and accounted for. So, any and all help is greatly appreciated. (Should have taken pics before hand, but that's neither here nor there)
    i dont see any pics..i dont think you uploaded them right
    New England F4

    feel free to pm me with any questions..

  4. #3
    Registered User
    Join Date
    Jul 2007
    Posts
    4
    hm... They appear for me... Here are the links to the pics:

    pic #1

    pic #2

    pic #3

    pic #4

  5. #4
    Registered User
    Join Date
    Jul 2007
    Posts
    4
    someone has informed me that pic #2 is an oil valve unique to 2.5L that's not on the 2.0L and that's why my service manual doesn't refer to it. I was also stated that it needs to be routed into the oil pathways towards the turbo. Any chance I might be able to get confirmation of this please?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •