brakes problem
Results 1 to 4 of 4

This is a discussion on brakes problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I recently installed stainless steel lines on my 04 sti and then bled the brakes using the sti manual. I ...

  1. #1
    Registered User awdlaunch132's Avatar
    Join Date
    Feb 2007
    Location
    georgia
    Posts
    15

    brakes problem

    I recently installed stainless steel lines on my 04 sti and then bled the brakes using the sti manual. I took it for a test drive and now my brakes are going straight to the floor. If i pump the brakes they come back for a second and then go away again. I thought i missed something and bled the brakes again with no affect at all. Is my brake booster bad or am i missing something. Also, I am NOT losing fluid anywhere. Thanks in advance.
    94 talon tsi 12.5@108 big 16g stock suspension -sold
    92 miata gc springs koni race shocks sways etc-sold
    04 sti cobb intake more to come.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,468
    I Support ClubWRX
    If there's no juice coming out then you need to bleed more.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User awdlaunch132's Avatar
    Join Date
    Feb 2007
    Location
    georgia
    Posts
    15
    alright so I gave up today and took it to a shop with a pressure bleeder. they said they got all of the air out and there still is a problem just not as bad. now if i push the pedal once it goes about halfway to the floor when i push it again it feels fine. anyone have a clue
    94 talon tsi 12.5@108 big 16g stock suspension -sold
    92 miata gc springs koni race shocks sways etc-sold
    04 sti cobb intake more to come.

  5. #4
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    Quote Originally Posted by awdlaunch132 View Post
    alright so I gave up today and took it to a shop with a pressure bleeder. they said they got all of the air out and there still is a problem just not as bad. now if i push the pedal once it goes about halfway to the floor when i push it again it feels fine. anyone have a clue
    you need to bleed the abs sytem.. i dunno what shop you brought it too but you abs control module should have been bleed..you didnt bleed your brakes properly..got air in your system..pushed it threw out you system..which includes your abs control module...only way to bleed it is with a abs system sequantial bleed..the car does it itself when in dealer check mode and the proper scan tool (sds system) is used..go to subaru tell them you have air in your abs controller and need it bled..prob solved...ive seen this about 7 times already..all caused by people getting the upgraded lines and improperly bleeding aftwerwards
    New England F4

    feel free to pm me with any questions..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •