WRX 04 ECU Calibration Code
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on WRX 04 ECU Calibration Code within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'm a WRX newbie since I just bought a used one a couple weeks back. I took it to the ...

  1. #1
    Registered User
    Join Date
    Jun 2007
    Posts
    3

    WRX 04 ECU Calibration Code

    I'm a WRX newbie since I just bought a used one a couple weeks back. I took it to the dealer to see if they could take a look at my low boost problem.

    I was told that the ECU is reporting the car as an '05 instead of an '04 and that the ECU calibration code does not match my VIN . What is the deal here? I have a feeling the previous owner was playing around with Enginuity.

    The car is 100% stock, but the dealer claims to be seeing 'aftermarket' bolts on the exhaust system. They also said the heat shield over the wastegate / turbo is missing.

    I'm really hoping this doesn't screw me on my warranty. Any thoughts as to why the ECU would be reporting this weird data back?

    Thank you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    Quote Originally Posted by Haelan View Post
    I'm a WRX newbie since I just bought a used one a couple weeks back. I took it to the dealer to see if they could take a look at my low boost problem.

    I was told that the ECU is reporting the car as an '05 instead of an '04 and that the ECU calibration code does not match my VIN . What is the deal here? I have a feeling the previous owner was playing around with Enginuity.

    The car is 100% stock, but the dealer claims to be seeing 'aftermarket' bolts on the exhaust system. They also said the heat shield over the wastegate / turbo is missing.

    I'm really hoping this doesn't screw me on my warranty. Any thoughts as to why the ECU would be reporting this weird data back?

    Thank you.
    well first off id check around underneath the car..and in the engine bay..look for signs of water damage..catrina is a bych...
    New England F4

    feel free to pm me with any questions..

  4. #3
    Registered User
    Join Date
    Jun 2007
    Posts
    3
    Thanks for the reply.

    The car was bought new and registered in Illinois with only one previous owner. To my knowledge (and carfax verified this) the vehicle never left that state or was registered elsewhere.

    I'm just concerned that the previous owner tried to use Enginuity with a tuned ROM for an '05. If he did, I'm surprised the car even runs. I'm just looking for any other explanation as to why the ECU would be reading as an '05 instead of '04. The heat shield over the wastegate is also missing so I'm assuming the exhaust had been modified at some point.

    Recently, with all the stock parts, exhaust etc., I've been getting ECU error code P0546 everytime I floor it in 5th gear at highway speeds. I really hope I didn't buy a lemon...

  5. #4
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    Quote Originally Posted by Haelan View Post
    Thanks for the reply.

    The car was bought new and registered in Illinois with only one previous owner. To my knowledge (and carfax verified this) the vehicle never left that state or was registered elsewhere.

    I'm just concerned that the previous owner tried to use Enginuity with a tuned ROM for an '05. If he did, I'm surprised the car even runs. I'm just looking for any other explanation as to why the ECU would be reading as an '05 instead of '04. The heat shield over the wastegate is also missing so I'm assuming the exhaust had been modified at some point.

    Recently, with all the stock parts, exhaust etc., I've been getting ECU error code P0546 everytime I floor it in 5th gear at highway speeds. I really hope I didn't buy a lemon...
    if the heat sheid is missing..and exhuast bolts are aftermarket i wouldnt be surprised it the car was modified..including the ecu.my bet is they had a pulg n play ecu installed and then installed a 05 ecu instead a 04 thinking it would be the same..
    New England F4

    feel free to pm me with any questions..

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •